aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-12-19 21:48:26 +0800
committermiwi <miwi@FreeBSD.org>2007-12-19 21:48:26 +0800
commitdfb6ef8d3419e478a3a0e0d4b5ba7c5e114b3659 (patch)
tree099bd97c217e07dadc9dad4303ac72f9de9f1e1d /databases
parent479f733e77b3e33dcbd823251071fbed5f39cc6a (diff)
downloadfreebsd-ports-graphics-dfb6ef8d3419e478a3a0e0d4b5ba7c5e114b3659.tar.gz
freebsd-ports-graphics-dfb6ef8d3419e478a3a0e0d4b5ba7c5e114b3659.tar.zst
freebsd-ports-graphics-dfb6ef8d3419e478a3a0e0d4b5ba7c5e114b3659.zip
This is a DataSource driver for Structures_DataGrid using PEAR::MDB2 and an
SQL query. WWW: http://pear.php.net/package/Structures_DataGrid_DataSource_MDB2/
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile28
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_MDB2/distinfo3
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_MDB2/pkg-descr4
4 files changed, 36 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index df7d25786ec..2365ae608fc 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -341,6 +341,7 @@
SUBDIR += pear-Structures_DataGrid_DataSource_CSV
SUBDIR += pear-Structures_DataGrid_DataSource_DBQuery
SUBDIR += pear-Structures_DataGrid_DataSource_DBTable
+ SUBDIR += pear-Structures_DataGrid_DataSource_MDB2
SUBDIR += pecl-memcache
SUBDIR += pecl-sqlite
SUBDIR += pgaccess
diff --git a/databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile b/databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile
new file mode 100644
index 00000000000..4de9905b167
--- /dev/null
+++ b/databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Structures_DataGrid_DataSource_MDB2
+# Date created: 19 Dec 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Structures_DataGrid_DataSource_MDB2
+PORTVERSION= 0.1.11
+CATEGORIES= databases www pear
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= DataSource driver using PEAR::MDB2 and an SQL query
+
+BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structures_DataGrid \
+ ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structures_DataGrid \
+ ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+
+USE_PHP= mysql
+
+CATEGORY= Structures
+
+FILES= DataGrid/DataSource/MDB2.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/databases/pear-Structures_DataGrid_DataSource_MDB2/distinfo b/databases/pear-Structures_DataGrid_DataSource_MDB2/distinfo
new file mode 100644
index 00000000000..f58c1092cac
--- /dev/null
+++ b/databases/pear-Structures_DataGrid_DataSource_MDB2/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Structures_DataGrid_DataSource_MDB2-0.1.11.tgz) = a3cf3471cc5c04d81eaadbeb214a2bc1
+SHA256 (PEAR/Structures_DataGrid_DataSource_MDB2-0.1.11.tgz) = 2853770876bc399e3f498caa1f75e2e0c7fbb2ec12ee152dc5212707b6102f12
+SIZE (PEAR/Structures_DataGrid_DataSource_MDB2-0.1.11.tgz) = 3497
diff --git a/databases/pear-Structures_DataGrid_DataSource_MDB2/pkg-descr b/databases/pear-Structures_DataGrid_DataSource_MDB2/pkg-descr
new file mode 100644
index 00000000000..73b73ef11e8
--- /dev/null
+++ b/databases/pear-Structures_DataGrid_DataSource_MDB2/pkg-descr
@@ -0,0 +1,4 @@
+This is a DataSource driver for Structures_DataGrid using PEAR::MDB2 and an
+SQL query.
+
+WWW: http://pear.php.net/package/Structures_DataGrid_DataSource_MDB2/