aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2009-11-18 01:07:59 +0800
committerdinoex <dinoex@FreeBSD.org>2009-11-18 01:07:59 +0800
commitdfb79f64e9bcecf7bb5fc0fcfe6b2cad980b74e0 (patch)
treee94a1ef7dee1b0413fe60fe5483113bd1042d946 /databases
parent85430d93cb2b44ff4735ecf92a897c1e904cf9e5 (diff)
downloadfreebsd-ports-graphics-dfb79f64e9bcecf7bb5fc0fcfe6b2cad980b74e0.tar.gz
freebsd-ports-graphics-dfb79f64e9bcecf7bb5fc0fcfe6b2cad980b74e0.tar.zst
freebsd-ports-graphics-dfb79f64e9bcecf7bb5fc0fcfe6b2cad980b74e0.zip
- Fix API break with ruby-postgres
Diffstat (limited to 'databases')
-rw-r--r--databases/ruby-dbd_pg/Makefile4
-rw-r--r--databases/ruby-dbd_pg/files/patch-Pg.rb18
2 files changed, 2 insertions, 20 deletions
diff --git a/databases/ruby-dbd_pg/Makefile b/databases/ruby-dbd_pg/Makefile
index d9b1971bc63..cb7a1c52b71 100644
--- a/databases/ruby-dbd_pg/Makefile
+++ b/databases/ruby-dbd_pg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dbd_pg
PORTVERSION= 0.3.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases ruby
MASTER_SITES= RF
MASTER_SITE_SUBDIR= ruby-dbi
@@ -19,7 +19,7 @@ MAINTAINER= ruby@FreeBSD.org
COMMENT= PostgreSQL driver for DBI-for-Ruby
RUN_DEPENDS= ${RUBY_SITELIBDIR}/dbi.rb:${PORTSDIR}/databases/ruby-dbi \
- ${RUBY_SITEARCHLIBDIR}/postgres.so:${PORTSDIR}/databases/ruby-postgres
+ ${RUBY_SITEARCHLIBDIR}/pg.so:${PORTSDIR}/databases/ruby-pg
USE_RUBY= yes
USE_RUBY_SETUP= yes
diff --git a/databases/ruby-dbd_pg/files/patch-Pg.rb b/databases/ruby-dbd_pg/files/patch-Pg.rb
deleted file mode 100644
index 8a1ab5d650d..00000000000
--- a/databases/ruby-dbd_pg/files/patch-Pg.rb
+++ /dev/null
@@ -1,18 +0,0 @@
---- lib/dbd/Pg.rb.orig 2009-07-11 19:07:38.000000000 +0200
-+++ lib/dbd/Pg.rb 2009-11-15 10:18:13.000000000 +0100
-@@ -31,13 +31,13 @@
-
- begin
- require 'rubygems'
-- gem 'pg'
-+ gem 'postgres'
- gem 'dbi'
- rescue Exception => e
- end
-
- require 'dbi'
--require 'pg'
-+require 'postgres'
-
- module DBI
- module DBD