aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-11-12 10:58:43 +0800
committerswills <swills@FreeBSD.org>2014-11-12 10:58:43 +0800
commitfb6acaf4f66450c0d50f314a562b2ef47b8b3b8e (patch)
tree31322c5097f38226d21dc826f1997b479114e330 /databases
parent3d41615bd860a29d6bd52a55885999122fb3b5db (diff)
downloadfreebsd-ports-graphics-fb6acaf4f66450c0d50f314a562b2ef47b8b3b8e.tar.gz
freebsd-ports-graphics-fb6acaf4f66450c0d50f314a562b2ef47b8b3b8e.tar.zst
freebsd-ports-graphics-fb6acaf4f66450c0d50f314a562b2ef47b8b3b8e.zip
Mark broken with Ruby 2.1
With hat: ruby@
Diffstat (limited to 'databases')
-rw-r--r--databases/rubygem-bdb1/Makefile8
-rw-r--r--databases/rubygem-memcache/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/databases/rubygem-bdb1/Makefile b/databases/rubygem-bdb1/Makefile
index 0fd47dc2dd4..d23e2d692ef 100644
--- a/databases/rubygem-bdb1/Makefile
+++ b/databases/rubygem-bdb1/Makefile
@@ -17,4 +17,10 @@ USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${RUBY_VER} == 2.1
+BROKEN= Does not build with Ruby 2.1
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/rubygem-memcache/Makefile b/databases/rubygem-memcache/Makefile
index 0738bf004da..72f7c02e328 100644
--- a/databases/rubygem-memcache/Makefile
+++ b/databases/rubygem-memcache/Makefile
@@ -18,4 +18,10 @@ RUBYGEM_AUTOPLIST= yes
GEM_ENV +=EXTERNAL_LIB="YES"
CONFIGURE_ARGS= "--with-opt-dir=${LOCALBASE}"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${RUBY_VER} == 2.1
+BROKEN= Does not build with Ruby 2.1
+.endif
+
+.include <bsd.port.post.mk>