aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/babytrans
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-03-25 17:40:16 +0800
committerpawel <pawel@FreeBSD.org>2014-03-25 17:40:16 +0800
commit2b4f16b731f80f386d6e44db52962275b18671be (patch)
tree2540f3d9a917b43279c12a4a951f62b7501fdab1 /deskutils/babytrans
parent8c0e89f562f120f111945f8f8412cad40ad966fb (diff)
downloadfreebsd-ports-graphics-2b4f16b731f80f386d6e44db52962275b18671be.tar.gz
freebsd-ports-graphics-2b4f16b731f80f386d6e44db52962275b18671be.tar.zst
freebsd-ports-graphics-2b4f16b731f80f386d6e44db52962275b18671be.zip
Add staging support
Diffstat (limited to 'deskutils/babytrans')
-rw-r--r--deskutils/babytrans/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/deskutils/babytrans/Makefile b/deskutils/babytrans/Makefile
index e5ed3581d17..2cdb035c0cc 100644
--- a/deskutils/babytrans/Makefile
+++ b/deskutils/babytrans/Makefile
@@ -10,26 +10,25 @@ MASTER_SITES= http://fjolliton.free.fr/babytrans/
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK+/GNOME front-end for Babylon Translator .dic files
-USES= pathfix gettext
+USES= gmake gettext pathfix
USE_GNOME= gtk12 gnomeprefix
GNU_CONFIGURE= yes
CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_GMAKE= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
-NO_STAGE= yes
post-patch:
.for file in de es fr pt_BR
@${REINPLACE_CMD} -e "s|CHARSET|ISO-8859-1|" \
-e "s|ENCODING|8bit|" ${WRKSRC}/po/${file}.po
.endfor
+ @${REINPLACE_CMD} '/destdir=/ s|=|=${STAGEDIR}|' \
+ ${WRKSRC}/po/Makefile.in.in
post-install:
- @${MKDIR} ${DATADIR}
- @${MKDIR} ${PREFIX}/share/applets/Utility
- ${INSTALL_DATA} ${WRKSRC}/config-file/dictionary ${DATADIR}
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/applets/Utility
+ ${INSTALL_DATA} ${WRKSRC}/config-file/dictionary ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>