aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/calibre
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2016-02-14 02:18:10 +0800
committermadpilot <madpilot@FreeBSD.org>2016-02-14 02:18:10 +0800
commit9b72dfca32fbb6fafc0017c59c81605a9104cd79 (patch)
treef4068a2db3b218f71b68adcfb6d9932fb5e8391f /deskutils/calibre
parent85cc6bc4af4f1a3a3246ee4be549117efa18e3ce (diff)
downloadfreebsd-ports-graphics-9b72dfca32fbb6fafc0017c59c81605a9104cd79.tar.gz
freebsd-ports-graphics-9b72dfca32fbb6fafc0017c59c81605a9104cd79.tar.zst
freebsd-ports-graphics-9b72dfca32fbb6fafc0017c59c81605a9104cd79.zip
Fix strange build issue related to xdg-utils.
This is just a workaround to fix the issue at hand. Reported by: Alex V. Petrov <alexvpetrov at gmail.com>, Christoph Moench-Tegeder <cmt at burggraben.net>, Walter Schwarzenfeld <w.schwarzenfeld at utanet.at> marino
Diffstat (limited to 'deskutils/calibre')
-rw-r--r--deskutils/calibre/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index a8e86852a9a..d85feefc567 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -97,10 +97,13 @@ do-install:
${STAGEDIR}${PREFIX}/share/applications \
${STAGEDIR}${PREFIX}/share/desktop-directories \
${STAGEDIR}${PREFIX}/share/mime/packages
+ # Create this file to avoid what looks like a bug in xdg-desktop-menu
+ @${TOUCH} ${STAGEDIR}${PREFIX}/share/applications/defaults.list
(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} \
${PYSETUP} install --prefix ${PREFIX} \
--staging-root ${STAGEDIR}${PREFIX})
- @${RM} ${STAGEDIR}${PREFIX}/bin/calibre-uninstall
+ @${RM} ${STAGEDIR}${PREFIX}/bin/calibre-uninstall \
+ ${STAGEDIR}${PREFIX}/share/applications/defaults.list
@${RMDIR} ${STAGEDIR}${PREFIX}/share/desktop-directories
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/calibre/calibre/plugins/*