aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/gkrellm-reminder2
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-05-22 05:57:28 +0800
committerpav <pav@FreeBSD.org>2004-05-22 05:57:28 +0800
commit60021b5a3676cb8ed679c5e831f115559d9f7ae7 (patch)
treee5f1147c0f8e9d21929ef053689a9a156ebb71af /deskutils/gkrellm-reminder2
parent6339cb7cdc70cb0596d0ea8e547e9e774788bc70 (diff)
downloadfreebsd-ports-graphics-60021b5a3676cb8ed679c5e831f115559d9f7ae7.tar.gz
freebsd-ports-graphics-60021b5a3676cb8ed679c5e831f115559d9f7ae7.tar.zst
freebsd-ports-graphics-60021b5a3676cb8ed679c5e831f115559d9f7ae7.zip
Add gkrellm-reminder2, a GKrellM 2.x plugin for reminding you of important
events. PR: ports/66026 Submitted by: Tobias Roth <ports@fsck.ch>
Diffstat (limited to 'deskutils/gkrellm-reminder2')
-rw-r--r--deskutils/gkrellm-reminder2/Makefile37
-rw-r--r--deskutils/gkrellm-reminder2/distinfo2
-rw-r--r--deskutils/gkrellm-reminder2/files/patch-Makefile19
-rw-r--r--deskutils/gkrellm-reminder2/pkg-descr7
4 files changed, 65 insertions, 0 deletions
diff --git a/deskutils/gkrellm-reminder2/Makefile b/deskutils/gkrellm-reminder2/Makefile
new file mode 100644
index 00000000000..567c36dab1c
--- /dev/null
+++ b/deskutils/gkrellm-reminder2/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: gkrellm-reminder2
+# Date Created: Tue Apr 27 11:55:02 CEST 2004
+# Whom: Tobias Roth <ports@fsck.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= reminder
+PORTVERSION= 2.0.0
+CATEGORIES= deskutils
+MASTER_SITES= http://web.wt.net/~billw/gkrellm/Plugins/ \
+ http://depot.fsck.ch/mirror/distfiles/
+PKGNAMEPREFIX= gkrellm-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@fsck.ch
+COMMENT= GKrellM2 plugin that reminds you of important events
+
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk20
+
+PLIST_FILES= libexec/gkrellm2/plugins/reminder.so
+PORTDOCS= README
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/reminder.so ${PREFIX}/libexec/gkrellm2/plugins/
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/deskutils/gkrellm-reminder2/distinfo b/deskutils/gkrellm-reminder2/distinfo
new file mode 100644
index 00000000000..88b42b678b9
--- /dev/null
+++ b/deskutils/gkrellm-reminder2/distinfo
@@ -0,0 +1,2 @@
+MD5 (gkrellm-reminder-2.0.0.tar.gz) = ae612a076e2d3ef4e6ee67bae406a98e
+SIZE (gkrellm-reminder-2.0.0.tar.gz) = 27459
diff --git a/deskutils/gkrellm-reminder2/files/patch-Makefile b/deskutils/gkrellm-reminder2/files/patch-Makefile
new file mode 100644
index 00000000000..23f61f4601f
--- /dev/null
+++ b/deskutils/gkrellm-reminder2/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile.orig Tue Apr 27 12:45:04 2004
++++ Makefile Tue Apr 27 12:48:01 2004
+@@ -1,13 +1,13 @@
+ GTK_INCLUDE = `pkg-config gtk+-2.0 --cflags`
+ GTK_LIB = `pkg-config gtk+-2.0 --libs`
+
+-CFLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE) -I/usr/pkg/include
++CFLAGS += -Wall -fPIC $(GTK_INCLUDE)
+
+ LIBS = $(GTK_LIB)
+
+-LFLAGS = -shared -L/usr/pkg/lib
++LFLAGS = -shared
+
+-CC = gcc
++CC ?= gcc
+
+ all: reminder.so
+
diff --git a/deskutils/gkrellm-reminder2/pkg-descr b/deskutils/gkrellm-reminder2/pkg-descr
new file mode 100644
index 00000000000..6cfc9154a64
--- /dev/null
+++ b/deskutils/gkrellm-reminder2/pkg-descr
@@ -0,0 +1,7 @@
+[from website]
+A useful plugin for GKrellM that can remind you of important events.
+Events can be scheduled inside GKrellM's configuration and will be
+displayed in gkrellm-reminder's panel.
+
+WWW: http://web.wt.net/~billw/gkrellm/Plugins.html
+Author: James Simonsen <simonjam@ucs.orst.edu>