aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/xpostitPlus
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2001-08-31 10:12:31 +0800
committerdwcjr <dwcjr@FreeBSD.org>2001-08-31 10:12:31 +0800
commitf12ba5ab412ed44e2a6fbf98d0beef75a62a0185 (patch)
tree99dc05b980c98624a449cb6b0ab0b03766014914 /deskutils/xpostitPlus
parent014d0c2ac01bdfe7951ebdda9d126618388af362 (diff)
downloadfreebsd-ports-graphics-f12ba5ab412ed44e2a6fbf98d0beef75a62a0185.tar.gz
freebsd-ports-graphics-f12ba5ab412ed44e2a6fbf98d0beef75a62a0185.tar.zst
freebsd-ports-graphics-f12ba5ab412ed44e2a6fbf98d0beef75a62a0185.zip
Make not fail when width or height = 0
Bump PORTREVISION PR: 23701 No Response: maintainer Submitted by: dgilbert@velocet.ca
Diffstat (limited to 'deskutils/xpostitPlus')
-rw-r--r--deskutils/xpostitPlus/Makefile1
-rw-r--r--deskutils/xpostitPlus/files/patch-notes.c20
2 files changed, 21 insertions, 0 deletions
diff --git a/deskutils/xpostitPlus/Makefile b/deskutils/xpostitPlus/Makefile
index 34dcd72c3fd..c8abc748b16 100644
--- a/deskutils/xpostitPlus/Makefile
+++ b/deskutils/xpostitPlus/Makefile
@@ -7,6 +7,7 @@
PORTNAME= XPostitPlus
PORTVERSION= 2.3
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= office
diff --git a/deskutils/xpostitPlus/files/patch-notes.c b/deskutils/xpostitPlus/files/patch-notes.c
new file mode 100644
index 00000000000..63fd0e7d4c2
--- /dev/null
+++ b/deskutils/xpostitPlus/files/patch-notes.c
@@ -0,0 +1,20 @@
+*** note.c.orig Wed Dec 20 17:15:34 2000
+--- note.c Wed Dec 20 17:20:15 2000
+***************
+*** 359,364 ****
+--- 359,373 ----
+ }
+ }
+
++ /*
++ * The problem is that texth == 0 or textw == 0 causes an ungraceful exit.
++ * In this case, we set them all to a standard size.
++ */
++ if(texth == 0 || textw == 0)
++ {
++ texth = 169;
++ textw = 227;
++ }
+
+ /*
+ * Get the index number of this note.