aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/yank/Makefile
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-11-13 22:45:08 +0800
committertrevor <trevor@FreeBSD.org>2003-11-13 22:45:08 +0800
commit98d7950e05980253d33259a6aafcd5e3b6547fdb (patch)
tree1cbd7ce2d9411420b33e9f045481bd24f68ef920 /deskutils/yank/Makefile
parenta959d36850b787f6723176962c2985587b2936cb (diff)
downloadfreebsd-ports-graphics-98d7950e05980253d33259a6aafcd5e3b6547fdb.tar.gz
freebsd-ports-graphics-98d7950e05980253d33259a6aafcd5e3b6547fdb.tar.zst
freebsd-ports-graphics-98d7950e05980253d33259a6aafcd5e3b6547fdb.zip
Use the FIND and XARGS macros introduced in bsd.port.mk 1.391.
Diffstat (limited to 'deskutils/yank/Makefile')
-rw-r--r--deskutils/yank/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/deskutils/yank/Makefile b/deskutils/yank/Makefile
index 647bb79d1f9..f0df83d9797 100644
--- a/deskutils/yank/Makefile
+++ b/deskutils/yank/Makefile
@@ -27,10 +27,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
pre-patch:
@${PERL} -pi -e 's^-l(pthread|c_r)^${PTHREAD_LIBS}^g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
's^\$\(datadir\)/gnome/^\$\(datadir\)/^g ; \
s^\$\(datadir\)/locale^\$\(prefix\)/share/locale^g'
- @find ${WRKSRC}/src/Plugins -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC}/src/Plugins -name "Makefile.in" | \
+ ${XARGS} ${PERL} -pi -e \
's|_la_LDFLAGS =|_la_LDFLAGS = -avoid-version|g'
.include <bsd.port.mk>