aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-04 23:13:42 +0800
committerbapt <bapt@FreeBSD.org>2013-06-04 23:13:42 +0800
commit49d0c5ffe215b688be077f3e0d0fdf105e9fe908 (patch)
tree0b36792fa675c2edf5b15e43588e3ae7a3958ffc /deskutils
parent9e082b72a0776c33f71efc2bb2b7a5feac9b641f (diff)
downloadfreebsd-ports-graphics-49d0c5ffe215b688be077f3e0d0fdf105e9fe908.tar.gz
freebsd-ports-graphics-49d0c5ffe215b688be077f3e0d0fdf105e9fe908.tar.zst
freebsd-ports-graphics-49d0c5ffe215b688be077f3e0d0fdf105e9fe908.zip
Convert to new options framework
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/google-gadgets/Makefile79
-rw-r--r--deskutils/remember.el/Makefile15
2 files changed, 42 insertions, 52 deletions
diff --git a/deskutils/google-gadgets/Makefile b/deskutils/google-gadgets/Makefile
index b06f8bf0de7..5545528e6fb 100644
--- a/deskutils/google-gadgets/Makefile
+++ b/deskutils/google-gadgets/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: google-gadgets
-# Date created: 2008-06-08
-# Whom: Ashish Shukla <wahjava@gmail.com>
-#
+# Created by: Ashish Shukla <wahjava@gmail.com>
# $FreeBSD$
-#
PORTNAME= google-gadgets
PORTVERSION= 0.11.2
@@ -46,32 +42,34 @@ WANT_GNOME= yes
USES= pathfix
INSTALLS_ICONS= yes
-OPTIONS= DEBUGGING "Enable debug output on runtime" on\
- GTK "Build GTK Host" on\
- QT "Build Qt Host" on\
- GTKWEBKIT "Build with GTK Webkit support" on\
- MOZILLA "Build with Mozilla support" on
+OPTIONS_DEFINE= DEBUGGING GTKWEBKIT MOZILLA
+OPTIONS_DEFAULT= DEBUGGING GTK QT GTKWEBKIT MOZILLA
+OPTIONS_MULTI= UI
+OPTIONS_MULTI_UI= GTK QT
+UI_DESC= Host toolkit
+DEBUGGING_DESC= debug output on runtime
+GTK_DESC= Build GTK Host
+QT_DESC= Build Qt Host
+GTKWEBKIT_DESC= Build with GTK Webkit support
+MOZILLA_DESC= Build with Mozilla support
.include <bsd.port.options.mk>
-.if defined(WITH_QT)
+.if ${PORT_OPTIONS:MQT}
USE_QT4= webkit opengl gui corelib script network moc_build
.endif
-.if defined(WITH_GTKWEBKIT)
+.if ${PORT_OPTIONS:MGTKWEBKIT}
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/webkit-1.0.pc:${PORTSDIR}/www/webkit-gtk2
LIB_DEPENDS+= webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
.endif
-.if defined(WITH_MOZILLA)
+.if ${PORT_OPTIONS:MMOZILLA}
USE_GECKO= libxul19
.endif
-.if defined(WITHOUT_GTKWEBKIT) && defined(WITHOUT_MOZILLA) && defined(WITH_GTK)
-IGNORE= gtk host requires GTK Webkit or/and Mozilla support to be enabled. Please, rerun 'make config'
-.elif defined(WITH_GTKWEBKIT) && defined(WITHOUT_GTK)
-.undef WITHOUT_GTK
-WITH_GTK=yes
+.if ${PORT_OPTIONS:MGTKWEBKIT} && ! ${PORT_OPTIONS:MGTK}
+PORT_OPTIONS+= GTK
pre-everything::
@${ECHO_MSG} "==> GTK Webkit or/and Mozilla support is enabled."
@@ -83,11 +81,19 @@ pre-everything::
CPPFLAGS+= -I${LOCALBASE}/include -Wno-deprecated-declarations
-.if defined(WITH_DEBUGGING)
+.if ${PORT_OPTIONS:MDEBUGGING}
CONFIGURE_ARGS+= --enable-debug
.endif
-.if defined(WITHOUT_GTK)
+.if ${PORT_OPTIONS:MGTK}
+USE_GNOME= gtk20
+PLIST_SUB+= GTK=""
+CONFIGURE_ARGS+= --enable-gtk-host
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/libsoup-2.4.pc:${PORTSDIR}/devel/libsoup
+LIB_DEPENDS+= soup-2.4.1:${PORTSDIR}/devel/libsoup
+RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+CONFIGURE_ARGS+= --with-ssl-ca-file=${LOCALBASE}/share/certs/ca-root-nss.crt
+.else
PLIST_SUB+= GTK="@comment "
CONFIGURE_ARGS+= --disable-gtk-host \
--disable-libggadget-gtk \
@@ -96,42 +102,29 @@ CONFIGURE_ARGS+= --disable-gtk-host \
--disable-webkit-script-runtime \
--disable-gtkwebkit-browser-element \
--disable-soup-xml-http-request
-.elif defined(WITH_GTK)
-USE_GNOME= gtk20
-PLIST_SUB+= GTK=""
-CONFIGURE_ARGS+= --enable-gtk-host
-BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/libsoup-2.4.pc:${PORTSDIR}/devel/libsoup
-LIB_DEPENDS+= soup-2.4.1:${PORTSDIR}/devel/libsoup
-RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
-CONFIGURE_ARGS+= --with-ssl-ca-file=${LOCALBASE}/share/certs/ca-root-nss.crt
-
.endif
-.if defined(WITHOUT_GTKWEBKIT)
+.if ${PORT_OPTIONS:MGTKWEBKIT}
+PLIST_SUB+= GTKWEBKIT=""
PLIST_SUB+= GTKWEBKIT="@comment "
+.else
CONFIGURE_ARGS+= --disable-webkit-script-runtime --disable-gtkwebkit-browser-element
-.elif defined(WITH_GTKWEBKIT)
-PLIST_SUB+= GTKWEBKIT=""
.endif
-.if defined(WITHOUT_MOZILLA)
+.if ${PORT_OPTIONS:MMOZILLA}
+PLIST_SUB+= MOZILLA=""
+.else
PLIST_SUB+= MOZILLA="@comment "
CONFIGURE_ARGS+= --disable-smjs-script-runtime --disable-gtkmoz-browser-element
-.elif defined(WITH_MOZILLA)
-PLIST_SUB+= MOZILLA=""
.endif
-.if defined(WITHOUT_QT)
+.if ${PORT_OPTIONS:MQT}
+PLIST_SUB+= QT=""
+CONFIGURE_ARGS+= --enable-qt-host
+.else
PLIST_SUB+= QT="@comment "
CONFIGURE_ARGS+= --disable-qt-host --disable-libggadget-qt --disable-qt-system-framework\
--disable-qtwebkit-browser-element --disable-qt-script-runtime --disable-qt-xml-http-request
-.else
-PLIST_SUB+= QT=""
-CONFIGURE_ARGS+= --enable-qt-host
-.endif
-
-.if defined(WITHOUT_QT) && defined(WITHOUT_GTK)
-IGNORE= requires GTK or/and Qt host to be enabled. Please, rerun 'make config'
.endif
post-patch:
diff --git a/deskutils/remember.el/Makefile b/deskutils/remember.el/Makefile
index 1294132fc09..0f0df3e4d7c 100644
--- a/deskutils/remember.el/Makefile
+++ b/deskutils/remember.el/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: remember.el
-# Date created: March 09 2005
-# Whom: Dryice Liu <dryice@liu.com.cn>
-#
+# Created by: Dryice Liu <dryice@liu.com.cn>
# $FreeBSD$
-#
PORTNAME= remember.el
PORTVERSION= 2.0
@@ -21,8 +17,9 @@ USE_GMAKE= yes
INFO= remember remember-extra
-OPTIONS= BBDB "BBDB support" off
-OPTIONS+= PLANNER "Planner.el support" off
+OPTIONS_DEFINE= BBDB PLANNER
+BBDB_DESC= BBDB support
+PLANNER_DESC= Planner.el support
.include <bsd.port.pre.mk>
@@ -30,7 +27,7 @@ OPTIONS+= PLANNER "Planner.el support" off
IGNORE= incorporated into Emacs 23/24
.endif
-.if !defined(WITHOUT_BBDB)
+.if ${PORT_OPTIONS:MBBDB}
.if ${EMACS_NAME} == "xemacs"
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/xemacs-packages/lisp/bbdb/bbdb-com.el:${PORTSDIR}/editors/xemacs-packages
.else
@@ -41,7 +38,7 @@ PLIST_SUB+= HAS_BBDB=""
PLIST_SUB+= HAS_BBDB="@comment "
.endif
-.if !defined(WITHOUT_PLANNER)
+.if ${PORT_OPTIONS:MPLANNER}
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_SITE_LISPDIR}/planner/planner.el:${PORTSDIR}/deskutils/planner.el
PLIST_SUB+= HAS_PLANNER=""
.else