aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-09-12 19:45:41 +0800
committermadpilot <madpilot@FreeBSD.org>2013-09-12 19:45:41 +0800
commit5101af06591caa5936fee0eda0e6ea4ce7defa86 (patch)
tree4e3b53b57a3d912518551fff8c5e867d89128f76 /deskutils
parentdc89b756b5321f97eb61e9a67bce125d43d5455a (diff)
downloadfreebsd-ports-graphics-5101af06591caa5936fee0eda0e6ea4ce7defa86.tar.gz
freebsd-ports-graphics-5101af06591caa5936fee0eda0e6ea4ce7defa86.tar.zst
freebsd-ports-graphics-5101af06591caa5936fee0eda0e6ea4ce7defa86.zip
- Update to 1.2.0
PR: ports/181939 Submitted by: Rusty Nejdl <rnejdl@ringofsaturn.com> (maintainer)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/calibre/Makefile3
-rw-r--r--deskutils/calibre/distinfo4
-rw-r--r--deskutils/calibre/files/patch-setup_install.py22
-rw-r--r--deskutils/calibre/pkg-plist16
4 files changed, 29 insertions, 16 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index a0ce3b84ef7..9100cd2715f 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= calibre
-PORTVERSION= 0.9.42
+PORTVERSION= 1.2.0
CATEGORIES= deskutils python
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
@@ -43,6 +43,7 @@ RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils \
${PYTHON_PKGNAMEPREFIX}dbus>=0:${PORTSDIR}/devel/py-dbus \
${PYTHON_PKGNAMEPREFIX}netifaces>=0:${PORTSDIR}/net/py-netifaces \
${PYTHON_PKGNAMEPREFIX}cssselect>=0:${PORTSDIR}/www/py-cssselect \
+ ${PYTHON_PKGNAMEPREFIX}apsw>=0:${PORTSDIR}/databases/py-apsw \
pdftohtml:${PORTSDIR}/graphics/poppler-utils \
lshal:${PORTSDIR}/sysutils/hal
diff --git a/deskutils/calibre/distinfo b/deskutils/calibre/distinfo
index 7487b495167..51f6f99bceb 100644
--- a/deskutils/calibre/distinfo
+++ b/deskutils/calibre/distinfo
@@ -1,2 +1,2 @@
-SHA256 (calibre-0.9.42.tar.xz) = 6cd64b54b4c0b696d9a6cfd50527c10cbd7b473a622f2e0f2e2ef81be680fe1f
-SIZE (calibre-0.9.42.tar.xz) = 29351712
+SHA256 (calibre-1.2.0.tar.xz) = d27fdbe981620aa63f5c70909c63a3a7b747ced1da2ee7065879f07b8a75ca40
+SIZE (calibre-1.2.0.tar.xz) = 29652528
diff --git a/deskutils/calibre/files/patch-setup_install.py b/deskutils/calibre/files/patch-setup_install.py
index dd850c5188c..ce8c5dd7fae 100644
--- a/deskutils/calibre/files/patch-setup_install.py
+++ b/deskutils/calibre/files/patch-setup_install.py
@@ -1,11 +1,11 @@
---- setup/install.py.orig 2011-06-14 14:16:28.000000000 -0500
-+++ setup/install.py 2011-06-14 14:16:39.000000000 -0500
-@@ -12,7 +12,7 @@
- __appname__, __version__)
-
- HEADER = '''\
--#!/usr/bin/env python2
-+#!/usr/bin/env python2.7
-
- """
- This is the standard runscript for all of calibre's tools.
+--- setup/install.py.orig 2013-09-06 06:28:39.000000000 +0200
++++ setup/install.py 2013-09-10 22:34:23.970135119 +0200
+@@ -160,7 +160,7 @@
+ self.info('Installing mount helper to '+ dest)
+ cflags = os.environ.get('OVERRIDE_CFLAGS', '-Wall -pedantic')
+ cflags = shlex.split(cflags)
+- p = subprocess.Popen(['gcc']+cflags+[src, '-o', dest])
++ p = subprocess.Popen([os.getenv('CC', 'gcc')]+cflags+[src, '-o', dest])
+ ret = p.wait()
+ if ret != 0:
+ return warn()
diff --git a/deskutils/calibre/pkg-plist b/deskutils/calibre/pkg-plist
index 1901d8ab445..106f2a69610 100644
--- a/deskutils/calibre/pkg-plist
+++ b/deskutils/calibre/pkg-plist
@@ -33,6 +33,7 @@ lib/calibre/calibre/db/backend.py
lib/calibre/calibre/db/backup.py
lib/calibre/calibre/db/cache.py
lib/calibre/calibre/db/categories.py
+lib/calibre/calibre/db/delete_service.py
lib/calibre/calibre/db/errors.py
lib/calibre/calibre/db/fields.py
lib/calibre/calibre/db/lazy.py
@@ -47,10 +48,13 @@ lib/calibre/calibre/db/tests/add_remove.py
lib/calibre/calibre/db/tests/base.py
lib/calibre/calibre/db/tests/filesystem.py
lib/calibre/calibre/db/tests/legacy.py
+lib/calibre/calibre/db/tests/locking.py
lib/calibre/calibre/db/tests/main.py
lib/calibre/calibre/db/tests/profiling.py
lib/calibre/calibre/db/tests/reading.py
+lib/calibre/calibre/db/tests/utils.py
lib/calibre/calibre/db/tests/writing.py
+lib/calibre/calibre/db/utils.py
lib/calibre/calibre/db/view.py
lib/calibre/calibre/db/write.py
lib/calibre/calibre/debug.py
@@ -231,6 +235,8 @@ lib/calibre/calibre/ebooks/docx/to_html.py
lib/calibre/calibre/ebooks/docx/toc.py
lib/calibre/calibre/ebooks/docx/block_styles.py
lib/calibre/calibre/ebooks/docx/lcid.py
+lib/calibre/calibre/ebooks/docx/writer/__init__.py
+lib/calibre/calibre/ebooks/docx/writer/container.py
lib/calibre/calibre/ebooks/epub/__init__.py
lib/calibre/calibre/ebooks/epub/pages.py
lib/calibre/calibre/ebooks/epub/periodical.py
@@ -596,6 +602,7 @@ lib/calibre/calibre/gui2/actions/save_to_disk.py
lib/calibre/calibre/gui2/actions/show_book_details.py
lib/calibre/calibre/gui2/actions/show_quickview.py
lib/calibre/calibre/gui2/actions/similar_books.py
+lib/calibre/calibre/gui2/actions/sort.py
lib/calibre/calibre/gui2/actions/store.py
lib/calibre/calibre/gui2/actions/toc_edit.py
lib/calibre/calibre/gui2/actions/tweak_epub.py
@@ -665,6 +672,8 @@ lib/calibre/calibre/gui2/convert/rb_output.py
lib/calibre/calibre/gui2/convert/rb_output_ui.py
lib/calibre/calibre/gui2/convert/regex_builder.py
lib/calibre/calibre/gui2/convert/regex_builder_ui.py
+lib/calibre/calibre/gui2/convert/rtf_input.py
+lib/calibre/calibre/gui2/convert/rtf_input_ui.py
lib/calibre/calibre/gui2/convert/search_and_replace.py
lib/calibre/calibre/gui2/convert/search_and_replace_ui.py
lib/calibre/calibre/gui2/convert/single.py
@@ -696,7 +705,6 @@ lib/calibre/calibre/gui2/dialogs/add_empty_book.py
lib/calibre/calibre/gui2/dialogs/add_from_isbn.py
lib/calibre/calibre/gui2/dialogs/add_from_isbn_ui.py
lib/calibre/calibre/gui2/dialogs/book_info.py
-lib/calibre/calibre/gui2/dialogs/book_info_ui.py
lib/calibre/calibre/gui2/dialogs/catalog.py
lib/calibre/calibre/gui2/dialogs/catalog_ui.py
lib/calibre/calibre/gui2/dialogs/check_library.py
@@ -776,6 +784,8 @@ lib/calibre/calibre/gui2/keyboard.py
lib/calibre/calibre/gui2/languages.py
lib/calibre/calibre/gui2/layout.py
lib/calibre/calibre/gui2/library/__init__.py
+lib/calibre/calibre/gui2/library/alternate_views.py
+lib/calibre/calibre/gui2/library/caches.py
lib/calibre/calibre/gui2/library/delegates.py
lib/calibre/calibre/gui2/library/models.py
lib/calibre/calibre/gui2/library/views.py
@@ -1042,6 +1052,7 @@ lib/calibre/calibre/translations/dynamic.py
lib/calibre/calibre/translations/msgfmt.py
lib/calibre/calibre/utils/Zeroconf.py
lib/calibre/calibre/utils/__init__.py
+lib/calibre/calibre/utils/apsw_shell.py
lib/calibre/calibre/utils/bibtex.py
lib/calibre/calibre/utils/browser.py
lib/calibre/calibre/utils/chm/__init__.py
@@ -1139,7 +1150,6 @@ lib/calibre/calibre/utils/threadpool.py
lib/calibre/calibre/utils/titlecase.py
lib/calibre/calibre/utils/unsmarten.py
lib/calibre/calibre/utils/unrar.py
-lib/calibre/calibre/utils/winshell.py
lib/calibre/calibre/utils/wmf/__init__.py
lib/calibre/calibre/utils/wmf/parse.py
lib/calibre/calibre/utils/wordcount.py
@@ -1480,6 +1490,7 @@ share/applications/calibre-lrfviewer.desktop
%%DATADIR%%/images/format-text-underline.png
%%DATADIR%%/images/forward.png
%%DATADIR%%/images/gmail_logo.png
+%%DATADIR%%/images/grid.png
%%DATADIR%%/images/help.png
%%DATADIR%%/images/heuristics.png
%%DATADIR%%/images/highlight_only_off.png
@@ -2037,6 +2048,7 @@ share/zsh/site-functions/_calibre
@dirrm lib/calibre/calibre/ebooks/html
@dirrm lib/calibre/calibre/ebooks/fb2
@dirrm lib/calibre/calibre/ebooks/epub
+@dirrm lib/calibre/calibre/ebooks/docx/writer
@dirrm lib/calibre/calibre/ebooks/docx
@dirrm lib/calibre/calibre/ebooks/djvu
@dirrm lib/calibre/calibre/ebooks/conversion/plugins