aboutsummaryrefslogtreecommitdiffstats
path: root/devel/avr-binutils
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2007-01-05 00:12:12 +0800
committerjoerg <joerg@FreeBSD.org>2007-01-05 00:12:12 +0800
commit27466c5de03bb51b1bc22840be8ef41375d99c5b (patch)
treec5230c6171a13c6fb0bb375e2beabaada373f856 /devel/avr-binutils
parent1d082bab9d1fa02a99e9383b74d11847dad7853a (diff)
downloadfreebsd-ports-graphics-27466c5de03bb51b1bc22840be8ef41375d99c5b.tar.gz
freebsd-ports-graphics-27466c5de03bb51b1bc22840be8ef41375d99c5b.tar.zst
freebsd-ports-graphics-27466c5de03bb51b1bc22840be8ef41375d99c5b.zip
Fix a compiler warning in the AVR-COFF generator that appeared with
GCC 4.x, and caused the compilation to fail due to the -Werror option used. Remove an annoying assembler warning in the ATmega256x patch that was frequently triggered by large C switch() statements in GCC, and generally considered to be a regression. The author of that patch agreed that the warning isn't particularly useful anyway for a number of reasons, and recommended to just drop it.
Diffstat (limited to 'devel/avr-binutils')
-rw-r--r--devel/avr-binutils/Makefile2
-rw-r--r--devel/avr-binutils/files/patch-atmega256x2
-rw-r--r--devel/avr-binutils/files/patch-coff-avr2
3 files changed, 3 insertions, 3 deletions
diff --git a/devel/avr-binutils/Makefile b/devel/avr-binutils/Makefile
index ea83be6985a..150a2b39337 100644
--- a/devel/avr-binutils/Makefile
+++ b/devel/avr-binutils/Makefile
@@ -7,7 +7,7 @@
PORTNAME= binutils
PORTVERSION= 2.17
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= binutils/releases
diff --git a/devel/avr-binutils/files/patch-atmega256x b/devel/avr-binutils/files/patch-atmega256x
index 5911f2abd24..ddc6e19c82c 100644
--- a/devel/avr-binutils/files/patch-atmega256x
+++ b/devel/avr-binutils/files/patch-atmega256x
@@ -1738,7 +1738,7 @@ diff -Nur gas/config/tc-avr.c gas/config/tc-avr.c
+ break;
+
+ default:
-+ as_warn (_("expression dangerous with linker stubs"));
++ break; /* as_warn (_("expression dangerous with linker stubs")); *//* Bjoern agreed. :) */
+ }
+ }
+ return reloc_to_return;
diff --git a/devel/avr-binutils/files/patch-coff-avr b/devel/avr-binutils/files/patch-coff-avr
index 3009a8acd59..dc7759f917f 100644
--- a/devel/avr-binutils/files/patch-coff-avr
+++ b/devel/avr-binutils/files/patch-coff-avr
@@ -2811,7 +2811,7 @@
+ shash->emitted = FALSE;
+ }
+ else
-+ coff_struct_hash_lookup (&info->structs, name,
++ (void)coff_struct_hash_lookup (&info->structs, name,
+ TRUE, tst->u.ts_struct.tagismalloced);
+
+ return TRUE;