aboutsummaryrefslogtreecommitdiffstats
path: root/devel/bison2/Makefile
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2002-03-13 09:23:26 +0800
committernaddy <naddy@FreeBSD.org>2002-03-13 09:23:26 +0800
commita967e47b07266e7a6cc0abff15c97d15588f5016 (patch)
treefffd921855a923abff8711f404af450cbdefc2e1 /devel/bison2/Makefile
parenta19ce0766432eda4d3b03318ee91c96a96deb6cc (diff)
downloadfreebsd-ports-graphics-a967e47b07266e7a6cc0abff15c97d15588f5016.tar.gz
freebsd-ports-graphics-a967e47b07266e7a6cc0abff15c97d15588f5016.tar.zst
freebsd-ports-graphics-a967e47b07266e7a6cc0abff15c97d15588f5016.zip
This requires ngettext().
XXX Explicitly build with included libintl for now. PR: 35653
Diffstat (limited to 'devel/bison2/Makefile')
-rw-r--r--devel/bison2/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/devel/bison2/Makefile b/devel/bison2/Makefile
index cb97e3ad4d5..05fe515556c 100644
--- a/devel/bison2/Makefile
+++ b/devel/bison2/Makefile
@@ -14,23 +14,23 @@ MASTER_SITE_SUBDIR= bison
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
+LIB_DEPENDS= giconv.2:${PORTSDIR}/converters/libiconv
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-included-gettext
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
MAKEINFO="makeinfo --no-split"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= bison.1
post-extract:
- ${RM} -f ${WRKSRC}/doc/bison.info*
+ @${RM} -f ${WRKSRC}/doc/bison.info*
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${PERL} -pi -e \
+ 's|-liconv|-lgiconv|g ; s|iconv\.h|giconv\.h|g'
post-install:
- @if [ ! -f ${PREFIX}/info/dir ]; then \
- ${SED} -ne '1,/Menu:/p' \/usr\/share\/info/dir > ${PREFIX}/info/dir; \
- fi
- @install-info ${PREFIX}/info/bison.info ${PREFIX}/info/dir
+ install-info ${PREFIX}/info/bison.info ${PREFIX}/info/dir
.include <bsd.port.mk>