aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cmake
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2008-08-26 15:58:40 +0800
committermakc <makc@FreeBSD.org>2008-08-26 15:58:40 +0800
commita1ea263bf95872d14813496b294df60126bc5da2 (patch)
tree4543c4bf35cb6c403fd0842d0c2486de81414096 /devel/cmake
parentc0a7f98123b763710708bc15ea6dde1325c79b4e (diff)
downloadfreebsd-ports-graphics-a1ea263bf95872d14813496b294df60126bc5da2.tar.gz
freebsd-ports-graphics-a1ea263bf95872d14813496b294df60126bc5da2.tar.zst
freebsd-ports-graphics-a1ea263bf95872d14813496b294df60126bc5da2.zip
Add ${LOCALBASE}/kde4 to the search paths for kde4-config. This is useful when
kde4-config in not in the PATH and PREFIX is set for non-default value. Approved by: miwi (mentor)
Diffstat (limited to 'devel/cmake')
-rw-r--r--devel/cmake/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/devel/cmake/Makefile b/devel/cmake/Makefile
index f434dd44a5d..57cff5cbbf7 100644
--- a/devel/cmake/Makefile
+++ b/devel/cmake/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cmake
PORTVERSION= 2.6.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.cmake.org/files/v${PORTVERSION:C/\.[[:digit:]]+$//}/ \
${MASTER_SITE_LOCAL}
@@ -35,5 +36,7 @@ MAN1= ccmake.1 \
post-patch:
@${GREP} -rl '/usr/X11R6' ${WRKSRC}/Modules ${WRKSRC}/Tests | \
${XARGS} ${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g'
+ @${REINPLACE_CMD} -e 's,/opt/kde4,${LOCALBASE}/kde4,g' \
+ ${WRKSRC}/Modules/FindKDE4.cmake
.include <bsd.port.mk>