aboutsummaryrefslogtreecommitdiffstats
path: root/devel/elfio
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-03-18 09:01:35 +0800
committerswills <swills@FreeBSD.org>2014-03-18 09:01:35 +0800
commit060b295ae56e2a4d82139152896b3aed2ecade30 (patch)
treed5b716ab6a8b9540df7c3488fb6de6a39899e572 /devel/elfio
parentae2d578f73602b20679cdcfd544da99e76a26efa (diff)
downloadfreebsd-ports-graphics-060b295ae56e2a4d82139152896b3aed2ecade30.tar.gz
freebsd-ports-graphics-060b295ae56e2a4d82139152896b3aed2ecade30.tar.zst
freebsd-ports-graphics-060b295ae56e2a4d82139152896b3aed2ecade30.zip
- Staging support
- Fixed port options - Added LICENSE PR: ports/187627 Submitted by: Bartek Rutkowski <ports@robakdesign.com>
Diffstat (limited to 'devel/elfio')
-rw-r--r--devel/elfio/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/devel/elfio/Makefile b/devel/elfio/Makefile
index f2551fc496c..08347a27325 100644
--- a/devel/elfio/Makefile
+++ b/devel/elfio/Makefile
@@ -3,7 +3,7 @@
PORTNAME= elfio
PORTVERSION= 1.0.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/ELFIO-sources/ELFIO-${PORTVERSION}
DISTNAME= ${PORTNAME:U}-${PORTVERSION}
@@ -11,6 +11,8 @@ DISTNAME= ${PORTNAME:U}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ library for reading and generating files in the ELF binary format
+LICENSE= LGPL21
+
BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool
GNU_CONFIGURE= yes
@@ -23,10 +25,6 @@ OPTIONE_DEFINE= EXAMPLES DOCS
PORTDOCS= *
-NO_STAGE= yes
-
-OPTIONS_DEFINE= DOCS EXAMPLES
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MEXAMPLES}
@@ -45,18 +43,18 @@ pre-configure:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in AUTHORS ChangeLog README
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
.for f in elf11g.zip tutorial.docbook tutorial.pdf
- ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@${FIND} ${WRKSRC}/Examples/ -name "*.cpp" -exec ${INSTALL_DATA} {} \
- ${EXAMPLESDIR}/ \;
+ ${STAGEDIR}${EXAMPLESDIR}/ \;
.endif
.include <bsd.port.mk>