aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gdb66
diff options
context:
space:
mode:
authormp <mp@FreeBSD.org>2002-06-08 00:25:16 +0800
committermp <mp@FreeBSD.org>2002-06-08 00:25:16 +0800
commitcf1c22bd80cf151f4fe0b494e097618660fed09b (patch)
tree6dc8b53c3918c383beebfe77cdd54d221bc02e66 /devel/gdb66
parentb0bdb256b1e04b4d0a4766b29775c0cba92973be (diff)
downloadfreebsd-ports-graphics-cf1c22bd80cf151f4fe0b494e097618660fed09b.tar.gz
freebsd-ports-graphics-cf1c22bd80cf151f4fe0b494e097618660fed09b.tar.zst
freebsd-ports-graphics-cf1c22bd80cf151f4fe0b494e097618660fed09b.zip
Fix internal assertion error.
Noticed by: Jun Kuriyama <kuriyama@imgsrc.co.jp>
Diffstat (limited to 'devel/gdb66')
-rw-r--r--devel/gdb66/Makefile2
-rw-r--r--devel/gdb66/files/patch-gdb_config_i386_tm-fbsd.h6
2 files changed, 3 insertions, 5 deletions
diff --git a/devel/gdb66/Makefile b/devel/gdb66/Makefile
index 01a7b3eff04..9e088029f15 100644
--- a/devel/gdb66/Makefile
+++ b/devel/gdb66/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gdb
PORTVERSION= 5.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= gdb/releases
diff --git a/devel/gdb66/files/patch-gdb_config_i386_tm-fbsd.h b/devel/gdb66/files/patch-gdb_config_i386_tm-fbsd.h
index 3013085bb6f..d1d4a22c528 100644
--- a/devel/gdb66/files/patch-gdb_config_i386_tm-fbsd.h
+++ b/devel/gdb66/files/patch-gdb_config_i386_tm-fbsd.h
@@ -1,5 +1,5 @@
--- gdb/config/i386/tm-fbsd.h Sat Jul 28 10:03:38 2001
-+++ gdb/config/i386/tm-fbsd.h Mon Jun 3 10:08:22 2002
++++ gdb/config/i386/tm-fbsd.h Fri Jun 7 08:32:14 2002
@@ -24,6 +24,10 @@
#define HAVE_I387_REGS
#include "i386/tm-i386.h"
@@ -11,7 +11,7 @@
/* FreeBSD/ELF uses stabs-in-ELF with the DWARF register numbering
scheme by default, so we must redefine STAB_REG_TO_REGNUM. This
messes up the floating-point registers for a.out, but there is not
-@@ -41,38 +45,44 @@
+@@ -41,38 +45,42 @@
/* Support for longjmp. */
/* Details about jmp_buf. It's supposed to be an array of integers. */
@@ -22,8 +22,6 @@
-/* Figure out where the longjmp will land. Store the address that
- longjmp will jump to in *ADDR, and return non-zero if successful. */
-
-+#undef NUM_REGS
-+#define NUM_REGS 16
#define GET_LONGJMP_TARGET(addr) get_longjmp_target (addr)
-extern int get_longjmp_target (CORE_ADDR *addr);