aboutsummaryrefslogtreecommitdiffstats
path: root/devel/git
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2016-02-05 01:33:13 +0800
committeradamw <adamw@FreeBSD.org>2016-02-05 01:33:13 +0800
commit5d5ba7c5ac3f574d2c82e37bcd3ca6aff7aaa961 (patch)
tree4e5232cd78b47bf12de0007f0cbaf2688f8eaa10 /devel/git
parent671d06e6e357500b23c04234661eae85a5c58f0e (diff)
downloadfreebsd-ports-graphics-5d5ba7c5ac3f574d2c82e37bcd3ca6aff7aaa961.tar.gz
freebsd-ports-graphics-5d5ba7c5ac3f574d2c82e37bcd3ca6aff7aaa961.tar.zst
freebsd-ports-graphics-5d5ba7c5ac3f574d2c82e37bcd3ca6aff7aaa961.zip
Lighten up the Perl dependencies.
git uses Perl for two things: Perl hooks into git, and the git-send-email(1) script. The Perl hooks only use p5-Error. The other modules dependencies, p5-Authen-SASL and p5-Net-SMTP-SSL (which bring in a number of other perl module dependencies) are only required for git-send-email(1). This commit adds a SEND_EMAIL option, defaulted to on, that auto-enables the PERL option and installs the git-send-email(1) script with the extra perl modules. With the PERL option on and SEND_EMAIL off, only the p5-Error module is required. No PORTREVISION bump as the default dependencies and plist haven't changed. PR: 206901 Approved by: garga (maintainer) Differential Revision: https://reviews.freebsd.org/D5179
Diffstat (limited to 'devel/git')
-rw-r--r--devel/git/Makefile13
-rw-r--r--devel/git/pkg-plist8
2 files changed, 12 insertions, 9 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 0581a8158b9..e697bc1316d 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -41,8 +41,8 @@ SHEBANG_FILES= *.perl */*.perl */*/*.perl */*.pl */*/*.pl */*/*/*.pl \
CONFIGURE_ARGS= --enable-pthreads=-pthread ac_cv_header_libcharset_h=no
OPTIONS_DEFINE= GUI SVN GITWEB CONTRIB P4 CVS HTMLDOCS PERL ICONV CURL \
- ETCSHELLS NLS
-OPTIONS_DEFAULT= CONTRIB P4 CVS PERL ICONV CURL ETCSHELLS NLS
+ ETCSHELLS SEND_EMAIL NLS
+OPTIONS_DEFAULT= CONTRIB P4 CVS PERL ICONV CURL ETCSHELLS SEND_EMAIL NLS
OPTIONS_SUB= yes
GITWEB_DESC= Install gitweb
@@ -51,6 +51,7 @@ P4_DESC= Enable Perforce support
CVS_DESC= Enable CVS support
HTMLDOCS_DESC= Install additional documentation
ETCSHELLS_DESC= Modify /etc/shells
+SEND_EMAIL_DESC=Enable the git-send-email(1) script
NLS_USES= gettext
NLS_MAKE_ARGS_OFF= NO_GETTEXT=yes
@@ -58,11 +59,13 @@ NLS_MAKE_ARGS_OFF= NO_GETTEXT=yes
PERL_USES= perl5
PERL_MAKE_ENV= PERL_PATH=${PERL}
PERL_BUILD_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error
-PERL_RUN_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error \
- p5-Net-SMTP-SSL>=0:${PORTSDIR}/mail/p5-Net-SMTP-SSL \
- p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL
+PERL_RUN_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error
PERL_MAKE_ARGS_OFF= NO_PERL=1
+SEND_EMAIL_IMPLIES= PERL
+SEND_EMAIL_RUN_DEPENDS= p5-Net-SMTP-SSL>=0:${PORTSDIR}/mail/p5-Net-SMTP-SSL \
+ p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL
+
ICONV_USES= iconv
ICONV_MAKE_ARGS_OFF= NO_ICONV=1
diff --git a/devel/git/pkg-plist b/devel/git/pkg-plist
index 2c889ed8452..26744609878 100644
--- a/devel/git/pkg-plist
+++ b/devel/git/pkg-plist
@@ -120,7 +120,7 @@ man/man1/git-rev-list.1.gz
man/man1/git-rev-parse.1.gz
man/man1/git-revert.1.gz
man/man1/git-rm.1.gz
-man/man1/git-send-email.1.gz
+%%SEND_EMAIL%%man/man1/git-send-email.1.gz
man/man1/git-send-pack.1.gz
man/man1/git-sh-setup.1.gz
man/man1/git-sh-i18n.1.gz
@@ -315,7 +315,7 @@ libexec/git-core/git-rev-list
libexec/git-core/git-rev-parse
libexec/git-core/git-revert
libexec/git-core/git-rm
-libexec/git-core/git-send-email
+%%SEND_EMAIL%%libexec/git-core/git-send-email
libexec/git-core/git-send-pack
libexec/git-core/git-sh-i18n
libexec/git-core/git-sh-i18n--envsubst
@@ -604,7 +604,7 @@ share/git-core/templates/info/exclude
%%HTMLDOCS%%%%DOCSDIR%%/git-rev-parse.html
%%HTMLDOCS%%%%DOCSDIR%%/git-revert.html
%%HTMLDOCS%%%%DOCSDIR%%/git-rm.html
-%%HTMLDOCS%%%%DOCSDIR%%/git-send-email.html
+%%SEND_EMAIL%%%%HTMLDOCS%%%%DOCSDIR%%/git-send-email.html
%%HTMLDOCS%%%%DOCSDIR%%/git-send-pack.html
%%HTMLDOCS%%%%DOCSDIR%%/git-sh-i18n.html
%%HTMLDOCS%%%%DOCSDIR%%/git-sh-i18n--envsubst.html
@@ -962,7 +962,7 @@ share/git-core/templates/info/exclude
%%HTMLDOCS%%%%DOCSDIR%%/git-check-attr.txt
%%HTMLDOCS%%%%DOCSDIR%%/config.txt
%%HTMLDOCS%%%%DOCSDIR%%/git-http-fetch.txt
-%%HTMLDOCS%%%%DOCSDIR%%/git-send-email.txt
+%%SEND_EMAIL%%%%HTMLDOCS%%%%DOCSDIR%%/git-send-email.txt
%%HTMLDOCS%%%%DOCSDIR%%/git-annotate.txt
%%HTMLDOCS%%%%DOCSDIR%%/gitmodules.txt
%%HTMLDOCS%%%%DOCSDIR%%/pull-fetch-param.txt
/+762 * Updated Ukrainian translation.Maxim Dziumanenko2005-08-231-2305/+2910 * added all the new gal widgets & a couple of other missing files. re-sortedNot Zed2005-06-211-5984/+7393 * Update Ukrainian translation.Maxim Dziumanenko2005-02-221-6419/+4940 * Updated Ukrainian translation.Maxim Dziumanenko2004-08-191-9998/+2956 * bump version. requiresJP Rosevear2004-08-141-382/+503 * bump version, requirementsJP Rosevear2004-08-031-603/+707 * bump version, requirementsJP Rosevear2004-07-201-302/+335 * bump version, requirementsJP Rosevear2004-07-051-3487/+4181 * Merge from release branch.JP Rosevear2004-06-041-1899/+1896 * bump versionJP Rosevear2004-05-201-3156/+3910 * distedJeffrey Stedfast2004-04-301-1993/+2741 * Merge from release branchJP Rosevear2004-04-201-809/+832 * bump version, requirementsJP Rosevear2004-04-031-2265/+2730 * bump version, requirementsJP Rosevear2004-03-061-1528/+1681 * bump version, libtool numbersJP Rosevear2004-02-101-1240/+1365 * bump requirements, versionJP Rosevear2004-01-271-1348/+1583 * bump version and requirementsJP Rosevear2004-01-131-1412/+2026 * bump version and gal, e-d-s and gtkhtml requirementsJP Rosevear2003-12-301-1483/+1671 * update version relianceJP Rosevear2003-12-081-2247/+3554 * updateJP Rosevear2003-11-071-1273/+1080 * remove dead fileJP Rosevear2003-10-311-15512/+8298 * 1.4.1 release.Ettore Perazzoli2003-06-261-556/+571 * 1.4.0!Ettore Perazzoli2003-06-031-321/+320 * Sync 1.3.92.Ettore Perazzoli2003-05-231-3/+3 * 1.3.91.Ettore Perazzoli2003-05-221-941/+1008 * 1.3.3.Ettore Perazzoli2003-04-301-799/+924 * The return of 1.3.2.Ettore Perazzoli2003-04-121-205/+205 * Sync for 1.3.2.Ettore Perazzoli2003-04-101-1813/+1979 * Updated Ukrainian translationYuri Syrota2003-04-021-2/+2 * Updated Ukrainian translationYuri Syrota2003-04-021-5/+5 * Updated Ukrainian translationYuri Syrota2003-04-021-22/+22 * Updated Ukrainian translationYuri Syrota2003-04-021-7/+7 * Updated Ukrainian translationYuri Syrota2003-04-021-281/+281 * Updated Ukrainian translationYuri Syrota2003-04-021-3/+3 * Updated Ukrainian translationYuri Syrota2003-04-021-276/+286 * Updated Ukrainian translationYuri Syrota2003-03-311-80/+80 * Updated Ukrainian translationYuri Syrota2003-03-311-22/+15 * Updated Ukrainian translationYuri Syrota2003-03-311-4/+4 * Updated Ukrainian translationYuri Syrota2003-03-311-3570/+3172 * Updated Ukrainian translationYuri Syrota2003-02-251-18/+12 * Updated Ukrainian translationYuri Syrota2003-02-241-64/+38 * Updated Ukrainian translationYuri Syrota2003-02-241-102/+102 * Updated Ukrainian translationYuri Syrota2003-02-241-310/+295 * Updated Ukrainian translationYuri Syrota2003-02-231-285/+291 * Updated Ukrainian translationYuri Syrota2003-02-231-88/+88 * Updated Ukrainian translationYuri Syrota2003-02-141-1221/+1266 * Updated Ukrainian translationYuri Syrota2003-01-301-111/+77 * Updated Ukrainian translationYuri Syrota2003-01-291-5366/+5415 * - 3092 translated messages, 761 fuzzy translations, 2471 untranslated messages.Andrew V. Samoilov2003-01-081-165/+110 * Sync for 1.1.90.Ettore Perazzoli2002-10-291-1013/+1085 * Sync for 1.1.2.Ettore Perazzoli2002-10-081-1450/+1674 * Sync for 1.1.1.Ettore Perazzoli2002-09-101-1163/+1280 * Update po files to speed up snap build.JP Rosevear2002-08-131-1719/+2184 * Updated Ukrainian translationYuri Syrota2002-07-041-3785/+2872 * Update .po files.JP Rosevear2002-06-281-3973/+4573 * UpdatedAndrew V. Samoilov2002-06-131-43/+29 * Use utf-8 instead of utf8 to avoid msgfmt's warning.Andrew V. Samoilov2002-06-131-154/+75 * Updated Ukrainian translation.Andrew V. Samoilov2002-06-131-143/+72 * UpdatedAndrew V. Samoilov2002-06-111-447/+306 * Update the po files to cut down on dist timeJP Rosevear2002-05-081-3207/+4774 * Updated Ukrainian translationYuri Syrota2002-02-221-256/+197 * Updated Ukrainian translationYuri Syrota2002-02-221-205/+186 * Updated Ukrainian TranslationYuri Syrota2002-02-211-4580/+17761 * Updated Ukrainian TranslationYuri Syrota2001-12-111-1369/+785 * Sync for 0.99.2.Ettore Perazzoli2001-11-151-340/+358 * 0.99.0.Ettore Perazzoli2001-11-061-265/+276 * Syncing up for the 0.16.100 internal release.Ettore Perazzoli2001-11-011-1601/+2235 * Updated Ukrainian TranslationYuri Syrota2001-10-271-19/+19 * Updated Ukrainian TranslationYuri Syrota2001-10-261-56/+40 * Updated Ukrainian TranslationYuri Syrota2001-10-261-34/+36 * Updated Ukrainian TranslationYuri Syrota2001-10-261-9/+9 * Updated Ukrainian TranslationYuri Syrota2001-10-261-18/+14 * Updated Ukrainian TranslationYuri Syrota2001-10-261-61/+51 * Updated Ukrainian TranslationYuri Syrota2001-10-261-87/+88 * Updated Ukrainian TranslationYuri Syrota2001-10-261-38/+26 * Updated Ukrainian TranslationYuri Syrota2001-10-261-44/+28 * Updated Ukrainian TranslationYuri Syrota2001-10-261-313/+215 * Updated Ukrainian TranslationYuri Syrota2001-10-251-371/+263 * Updated Ukrainian TranslationYuri Syrota2001-10-241-18/+15 * Updated Ukrainian TranslationYuri Syrota2001-10-241-593/+449 * Updated Ukrainian TranslationYuri Syrota2001-10-231-899/+821 * Updated Ukrainian TranslationYuri Syrota2001-10-191-1473/+1486 * Updated Ukrainian TranslationYuri Syrota2001-10-19