aboutsummaryrefslogtreecommitdiffstats
path: root/devel/git
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2012-10-25 10:22:48 +0800
committerwxs <wxs@FreeBSD.org>2012-10-25 10:22:48 +0800
commit68a758b763222e58d88ba8d1fa6edd8ce5d3f3ca (patch)
tree95f73b5c7b34f244237d1d1872fb9763c9621671 /devel/git
parent168869cd25753eed5edada07cb24d43e7d0652a5 (diff)
downloadfreebsd-ports-graphics-68a758b763222e58d88ba8d1fa6edd8ce5d3f3ca.tar.gz
freebsd-ports-graphics-68a758b763222e58d88ba8d1fa6edd8ce5d3f3ca.tar.zst
freebsd-ports-graphics-68a758b763222e58d88ba8d1fa6edd8ce5d3f3ca.zip
Update to 1.8.0.
Something to be aware of from the release notes: <snip> In the next major release (not *this* one), we will change the behavior of the "git push" command. When "git push [$there]" does not say what to push, we have used the traditional "matching" semantics so far (all your branches were sent to the remote as long as there already are branches of the same name over there). We will use the "simple" semantics that pushes the current branch to the branch with the same name, only when the current branch is set to integrate with that remote branch. There is a user preference configuration variable "push.default" to change this, and "git push" will warn about the upcoming change until you set this variable in this release. "git branch --set-upstream" is deprecated and may be removed in a relatively distant future. "git branch [-u|--set-upstream-to]" has been introduced with a saner order of arguments. </snip> Feature safe: yes
Diffstat (limited to 'devel/git')
-rw-r--r--devel/git/Makefile2
-rw-r--r--devel/git/distinfo12
-rw-r--r--devel/git/pkg-plist9
3 files changed, 16 insertions, 7 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 56f117f0d0d..37d5353b8ea 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= git
-PORTVERSION= 1.7.12.4
+PORTVERSION= 1.8.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
diff --git a/devel/git/distinfo b/devel/git/distinfo
index fd4df52e857..d4de16a0ff0 100644
--- a/devel/git/distinfo
+++ b/devel/git/distinfo
@@ -1,6 +1,6 @@
-SHA256 (git-1.7.12.4.tar.gz) = 17e545929c16b5efa8fa9545936297d41571521cd7667fb74f92bd7adc8b63da
-SIZE (git-1.7.12.4.tar.gz) = 4109554
-SHA256 (git-manpages-1.7.12.4.tar.gz) = 4075b60250f9bc5b5323266764c889f028521dbe1f5c10f470a167cc75105005
-SIZE (git-manpages-1.7.12.4.tar.gz) = 521602
-SHA256 (git-htmldocs-1.7.12.4.tar.gz) = 580de99c9fd8bed49132cf137af643d64e1450a7917b77c1343a784048a95930
-SIZE (git-htmldocs-1.7.12.4.tar.gz) = 1798333
+SHA256 (git-1.8.0.tar.gz) = ccc32f18ea12ea730a7d1d9d3d7bf51447439299a99d4d326f49f1f8bb488974
+SIZE (git-1.8.0.tar.gz) = 4225055
+SHA256 (git-manpages-1.8.0.tar.gz) = 8914907f9d22b9a6a0ade9a8addda9a84a2db35b23cbd404f2682cebc9114205
+SIZE (git-manpages-1.8.0.tar.gz) = 523324
+SHA256 (git-htmldocs-1.8.0.tar.gz) = b5837f19815c5259355fc2ac1ea320bd869680218b82b9a0802ca015c0e24363
+SIZE (git-htmldocs-1.8.0.tar.gz) = 1807615
diff --git a/devel/git/pkg-plist b/devel/git/pkg-plist
index 44896d0e210..61b6961eb68 100644
--- a/devel/git/pkg-plist
+++ b/devel/git/pkg-plist
@@ -189,6 +189,7 @@ libexec/git-core/git-verify-tag
libexec/git-core/git-web--browse
libexec/git-core/git-whatchanged
libexec/git-core/git-write-tree
+libexec/git-core/mergetools/codecompare
libexec/git-core/mergetools/deltawalker
libexec/git-core/mergetools/xxdiff
libexec/git-core/mergetools/tortoisemerge
@@ -952,6 +953,7 @@ share/git-core/templates/info/exclude
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.7.12.2.txt
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.7.12.3.txt
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.7.12.4.txt
+%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.8.0.txt
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/gitweb.cgi
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/static/gitweb.js
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/static/gitweb.css
@@ -978,9 +980,14 @@ share/git-core/templates/info/exclude
%%CONTRIB%%share/git-core/contrib/continuous/post-receive-cinotify
%%CONTRIB%%share/git-core/contrib/convert-objects/convert-objects.c
%%CONTRIB%%share/git-core/contrib/convert-objects/git-convert-objects.txt
+%%CONTRIB%%share/git-core/contrib/credential/gnome-keyring/Makefile
+%%CONTRIB%%share/git-core/contrib/credential/gnome-keyring/git-credential-gnome-keyring.c
+%%CONTRIB%%share/git-core/contrib/credential/gnome-keyring/.gitignore
%%CONTRIB%%share/git-core/contrib/credential/osxkeychain/Makefile
%%CONTRIB%%share/git-core/contrib/credential/osxkeychain/git-credential-osxkeychain.c
%%CONTRIB%%share/git-core/contrib/credential/osxkeychain/.gitignore
+%%CONTRIB%%share/git-core/contrib/credential/wincred/Makefile
+%%CONTRIB%%share/git-core/contrib/credential/wincred/git-credential-wincred.c
%%CONTRIB%%share/git-core/contrib/diff-highlight/README
%%CONTRIB%%share/git-core/contrib/diff-highlight/diff-highlight
%%CONTRIB%%share/git-core/contrib/emacs/.gitignore
@@ -1117,7 +1124,9 @@ share/git-core/templates/info/exclude
%%CONTRIB%%@dirrm share/git-core/contrib/completion
%%CONTRIB%%@dirrm share/git-core/contrib/continuous
%%CONTRIB%%@dirrm share/git-core/contrib/convert-objects
+%%CONTRIB%%@dirrm share/git-core/contrib/credential/gnome-keyring
%%CONTRIB%%@dirrm share/git-core/contrib/credential/osxkeychain
+%%CONTRIB%%@dirrm share/git-core/contrib/credential/wincred
%%CONTRIB%%@dirrm share/git-core/contrib/credential
%%CONTRIB%%@dirrm share/git-core/contrib/diffall
%%CONTRIB%%@dirrm share/git-core/contrib/diff-highlight