aboutsummaryrefslogtreecommitdiffstats
path: root/devel/kdestudio/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2001-03-06 22:22:39 +0800
committerdemon <demon@FreeBSD.org>2001-03-06 22:22:39 +0800
commit1b78b87200cdf1b5acbb6592cd60293773d41545 (patch)
treed51c70b4145ae341813e1988d656a5baea9faa48 /devel/kdestudio/Makefile
parentaf8f3b990d850daa844113538939289d689e33b0 (diff)
downloadfreebsd-ports-graphics-1b78b87200cdf1b5acbb6592cd60293773d41545.tar.gz
freebsd-ports-graphics-1b78b87200cdf1b5acbb6592cd60293773d41545.tar.zst
freebsd-ports-graphics-1b78b87200cdf1b5acbb6592cd60293773d41545.zip
New port: kdestudio.
KDE Studio is an IDE (integrated development environment) for the K Desktop Environment (KDE). PR: 24576 Submitted by: Trenton Schulz <twschulz@cord.edu>
Diffstat (limited to 'devel/kdestudio/Makefile')
-rw-r--r--devel/kdestudio/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/kdestudio/Makefile b/devel/kdestudio/Makefile
new file mode 100644
index 00000000000..dffea51cdee
--- /dev/null
+++ b/devel/kdestudio/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: kdestudio
+# Date created: Tuesday January 16, 2001
+# Whom: Trenton Schulz
+#
+# $FreeBSD$
+#
+
+PORTNAME= kdestudio
+PORTVERSION= 2.0.0
+CATEGORIES= devel kde
+MASTER_SITES= ftp://ftp.thekompany.com/pub/KDE_Studio/source/ \
+ http://gauss.cord.edu/homepages/twschulz/demo/
+
+MAINTAINER= twschulz@cord.edu
+
+LIB_DEPENDS= kdeui.4:${PORTSDIR}/x11/kdelibs2
+
+USE_QT2= yes
+MOC?= ${X11BASE}/bin/moc2
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
+ --with-qt-libraries=${X11BASE}/lib \
+ --with-extra-libs=${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include" \
+ MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
+ LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
+
+pre-configure:
+ @/usr/bin/find ${WRKSRC} -name Makefile.in | /usr/bin/xargs ${PERL} -pi -e "s/CXXFLAGS = -O2 -Wall/#CXXFLAGS = do not touch me/"
+
+.include <bsd.port.mk>