aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libbinio/Makefile
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-05-10 04:13:31 +0800
committerjylefort <jylefort@FreeBSD.org>2005-05-10 04:13:31 +0800
commita4a93a3adabdf131e4a7ab800779d81443c4e007 (patch)
treeb3ad6976a17c96252cb6eaa87e6a5874ef05845b /devel/libbinio/Makefile
parent9449aaa46dad8c538b15d7037e09ba4ecb5d7d4d (diff)
downloadfreebsd-ports-graphics-a4a93a3adabdf131e4a7ab800779d81443c4e007.tar.gz
freebsd-ports-graphics-a4a93a3adabdf131e4a7ab800779d81443c4e007.tar.zst
freebsd-ports-graphics-a4a93a3adabdf131e4a7ab800779d81443c4e007.zip
The binary I/O stream class library presents a platform-independent way to
access binary data streams in C++. The library is hardware independent in the form that it transparently converts between the different forms of machine-internal binary data representation. It further employs no special I/O protocol and can be used on arbitrary binary data sources. WWW: http://libbinio.sourceforge.net/ PR: ports/80727 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'devel/libbinio/Makefile')
-rw-r--r--devel/libbinio/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/libbinio/Makefile b/devel/libbinio/Makefile
new file mode 100644
index 00000000000..369beb48b15
--- /dev/null
+++ b/devel/libbinio/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libbinio
+# Date created: 10 August 2004
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libbinio
+PORTVERSION= 1.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Binary I/O stream class library
+
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS} ${CPPFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(SUBDIRS\ =\).*|\1 src|' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>