aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libdlmalloc
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1998-10-21 09:12:01 +0800
committersteve <steve@FreeBSD.org>1998-10-21 09:12:01 +0800
commit4e3cec9a47d5daedf7a93d0634ae2a0d12c59980 (patch)
treef9f6999291ca6157be2f95f2f5a3f306870d1823 /devel/libdlmalloc
parent8a0923be8bb2e53fb5f8bd0835bb99852f6b2497 (diff)
downloadfreebsd-ports-graphics-4e3cec9a47d5daedf7a93d0634ae2a0d12c59980.tar.gz
freebsd-ports-graphics-4e3cec9a47d5daedf7a93d0634ae2a0d12c59980.tar.zst
freebsd-ports-graphics-4e3cec9a47d5daedf7a93d0634ae2a0d12c59980.zip
Really convert to ELF. I forget the '-I' switch to patch when I
applied the last set of diffs.
Diffstat (limited to 'devel/libdlmalloc')
-rw-r--r--devel/libdlmalloc/files/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/devel/libdlmalloc/files/Makefile b/devel/libdlmalloc/files/Makefile
index c612752a594..5c21d801888 100644
--- a/devel/libdlmalloc/files/Makefile
+++ b/devel/libdlmalloc/files/Makefile
@@ -15,7 +15,11 @@
LIBDIR=${PREFIX}/lib
# for the shared lib stuff
+.if ${PORTOBJFORMAT} == "elf"
+VERSION=2
+.else
VERSION=2.6
+.endif
LIBMALLOC=libdlmalloc.a
LIBSMALLOC=libdlmalloc.so.${VERSION}
@@ -45,7 +49,11 @@ $(LIBMALLOC): $(OBJS)
$(LIBSMALLOC): $(SOBJS)
rm -f $(LIBSMALLOC)
+.if ${PORTOBJFORMAT} == "elf"
+ ld -Bshareable -soname $(LIBSMALLOC) -o $(LIBSMALLOC) $(SOBJS)
+.else
ld -Bshareable -o $(LIBSMALLOC) $(SOBJS)
+.endif
clean:
-rm -f *.o \#* *~ *.core a.out gmon.out mon.out onefile.c *.sL prof.out
@@ -54,6 +62,7 @@ install:
install -c -m 644 ${LIBMALLOC} $(LIBDIR)
-$(RANLIB) $(LIBDIR)/${LIBMALLOC}
install -c -m 555 ${LIBSMALLOC} $(LIBDIR)
+ ln -sf ${LIBSMALLOC} $(LIBDIR)/libdlmalloc.so
$(OBJS): $(SRCS)
$(SOBJS): $(SRCS)