aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libopensync
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-06-20 03:08:51 +0800
committerpav <pav@FreeBSD.org>2008-06-20 03:08:51 +0800
commitbf76cf03b6948a79c18826d3790175f2d5f73aaf (patch)
tree4edeabc5f233deb416554a950b3970029b861293 /devel/libopensync
parentf5e532b016356b6f843cc30b4e87cc691821813c (diff)
downloadfreebsd-ports-graphics-bf76cf03b6948a79c18826d3790175f2d5f73aaf.tar.gz
freebsd-ports-graphics-bf76cf03b6948a79c18826d3790175f2d5f73aaf.tar.zst
freebsd-ports-graphics-bf76cf03b6948a79c18826d3790175f2d5f73aaf.zip
- Update to 0.36
- Take maintainership PR: ports/124658 Submitted by: Alexander Logvinov <ports@logvinov.com>
Diffstat (limited to 'devel/libopensync')
-rw-r--r--devel/libopensync/Makefile39
-rw-r--r--devel/libopensync/distinfo6
-rw-r--r--devel/libopensync/files/patch-build_osync_support.py12
-rw-r--r--devel/libopensync/pkg-descr3
-rw-r--r--devel/libopensync/pkg-plist98
5 files changed, 84 insertions, 74 deletions
diff --git a/devel/libopensync/Makefile b/devel/libopensync/Makefile
index c35c09b5197..abb923293ef 100644
--- a/devel/libopensync/Makefile
+++ b/devel/libopensync/Makefile
@@ -6,35 +6,40 @@
#
PORTNAME= libopensync
-PORTVERSION= 0.31
-PORTREVISION= 1
+PORTVERSION= 0.36
CATEGORIES= devel
-MASTER_SITES= http://www.opensync.org/attachment/wiki/download/
-DISTNAME= libopensync-${PORTVERSION}
-EXTRACT_SUFX= .tar.bz2\?rev=\&format=raw
+MASTER_SITES= http://www.opensync.org/download/releases/${PORTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@logvinov.com
COMMENT= A PIM data synchronization framework
-CONFLICTS= libopensync-0.22*
-
+BUILD_DEPENDS= swig1.3:${PORTSDIR}/devel/swig13
LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
+RUN_DEPENDS= swig1.3:${PORTSDIR}/devel/swig13
+
+CONFLICTS= libopensync-0.22*
USE_BZIP2= yes
+USE_CMAKE= yes
+CMAKE_ARGS+= -Wno-dev
+CMAKE_USE_PTHREAD= yes
USE_GNOME= glib20 libxml2
+USE_PYTHON= yes
USE_LDCONFIG= yes
-USE_SCONS= yes
-SCONS_ARGS= prefix=${PREFIX}
+
+.include <bsd.port.pre.mk>
+
+SWIG_VER!= cd ${PORTSDIR}/devel/swig13 && ${MAKE} -V PORTVERSION
+SWIG_DATADIR!= cd ${PORTSDIR}/devel/swig13 && ${MAKE} -V DATADIR
post-patch:
- @${REINPLACE_CMD} -e "s|install_lib, 'pkgconfig'|install_prefix, 'libdata', 'pkgconfig'|" ${WRKSRC}/SConstruct
- @${REINPLACE_CMD} \
- -e 's|gthread-2.0|gthread-2.0 pthread|' \
- -e 's|vnum="%d.%d.%d" % ([^)]*)|vnum="%d" % (config["major"])|' \
- ${WRKSRC}/opensync/SConscript
+ @${REINPLACE_CMD} -e "s|\$${LIB_INSTALL_DIR}/pkgconfig|${PREFIX}/libdata/pkgconfig|" \
+ -e "s|FIND_PACKAGE( SWIG|FIND_PACKAGE( SWIG REQUIRED|" \
+ -e "/FIND_PACKAGE( Check )/d" ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e "s|/usr/local/share/swig1.3|${SWIG_DATADIR}/${SWIG_VER}|g" \
+ ${WRKSRC}/cmake/modules/FindSWIG.cmake
post-install:
- @${LN} -sf ${LOCALBASE}/lib/libopensync.so ${LOCALBASE}/lib/libopensync.so.1
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/libopensync/distinfo b/devel/libopensync/distinfo
index 1cfce08207f..c57f93d3bde 100644
--- a/devel/libopensync/distinfo
+++ b/devel/libopensync/distinfo
@@ -1,3 +1,3 @@
-MD5 (libopensync-0.31.tar.bz2?rev=&format=raw) = caf4fd1b174f4863ba79ab074a29b054
-SHA256 (libopensync-0.31.tar.bz2?rev=&format=raw) = bdbaae2a70e202ee90e6af500f22f3de81459a1cb0445c0668eeedf020d723a3
-SIZE (libopensync-0.31.tar.bz2?rev=&format=raw) = 862176
+MD5 (libopensync-0.36.tar.bz2) = d8cc7835663566e3626e959d8fb531bf
+SHA256 (libopensync-0.36.tar.bz2) = c686d27f0818e2d8cc6277ba123c74d7210e70fa2b320c5a828eaaedd598e908
+SIZE (libopensync-0.36.tar.bz2) = 879868
diff --git a/devel/libopensync/files/patch-build_osync_support.py b/devel/libopensync/files/patch-build_osync_support.py
deleted file mode 100644
index e52174171b6..00000000000
--- a/devel/libopensync/files/patch-build_osync_support.py
+++ /dev/null
@@ -1,12 +0,0 @@
-Significant whitespace considered harmful...
---- build/osync_support.py.orig 2007-06-21 14:38:39.000000000 +0200
-+++ build/osync_support.py 2008-03-09 19:32:41.000000000 +0100
-@@ -54,7 +54,7 @@
- else:
- # bad, nothing is available, tell the user
- print "No build directories found for your platform '%s'" % platform
-- return None
-+ return None
-
- print "Found directory %s, will build there" % target_dir
- return target_dir
diff --git a/devel/libopensync/pkg-descr b/devel/libopensync/pkg-descr
index 125b9a80fc6..3aad76b89c5 100644
--- a/devel/libopensync/pkg-descr
+++ b/devel/libopensync/pkg-descr
@@ -2,4 +2,5 @@ OpenSync is a PIM (Personal Information Management) data synchronization
framework that consists of several plug-ins that can be used to
connect to different devices and systems. For a list of currently supported
devices see http://www.opensync.org/wiki/DeviceCompatibilityList.
-WWW: http://www.opensync.org/wiki/Evo2-File
+
+WWW: http://www.opensync.org/
diff --git a/devel/libopensync/pkg-plist b/devel/libopensync/pkg-plist
index 699374be45f..12aca52e90e 100644
--- a/devel/libopensync/pkg-plist
+++ b/devel/libopensync/pkg-plist
@@ -1,36 +1,44 @@
-bin/osplugin
bin/osyncbinary
bin/osyncdump
include/opensync-1.0/opensync/archive/opensync_archive.h
+include/opensync-1.0/opensync/client/opensync_client.h
+include/opensync-1.0/opensync/client/opensync_client_proxy.h
include/opensync-1.0/opensync/data/opensync_change.h
include/opensync-1.0/opensync/data/opensync_data.h
-include/opensync-1.0/opensync/engine/opensync_engine.h
+include/opensync-1.0/opensync/db/opensync_db.h
+include/opensync-1.0/opensync/engine/opensync_mapping_engine.h
include/opensync-1.0/opensync/engine/opensync_obj_engine.h
include/opensync-1.0/opensync/engine/opensync_status.h
-include/opensync-1.0/opensync/file.h
-include/opensync-1.0/opensync/format/opensync_converter.h
-include/opensync-1.0/opensync/format/opensync_filter.h
+include/opensync-1.0/opensync/engine/opensync_engine.h
+include/opensync-1.0/opensync/format/opensync_time.h
include/opensync-1.0/opensync/format/opensync_format_env.h
include/opensync-1.0/opensync/format/opensync_objformat.h
-include/opensync-1.0/opensync/format/opensync_time.h
+include/opensync-1.0/opensync/format/opensync_filter.h
+include/opensync-1.0/opensync/format/opensync_converter.h
include/opensync-1.0/opensync/group/opensync_group.h
include/opensync-1.0/opensync/group/opensync_group_env.h
include/opensync-1.0/opensync/group/opensync_member.h
-include/opensync-1.0/opensync/helper/opensync_anchor.h
include/opensync-1.0/opensync/helper/opensync_hashtable.h
+include/opensync-1.0/opensync/helper/opensync_anchor.h
include/opensync-1.0/opensync/ipc/opensync_message.h
include/opensync-1.0/opensync/ipc/opensync_queue.h
include/opensync-1.0/opensync/ipc/opensync_serializer.h
-include/opensync-1.0/opensync/mapping/opensync_mapping.h
include/opensync-1.0/opensync/mapping/opensync_mapping_entry.h
+include/opensync-1.0/opensync/mapping/opensync_mapping.h
include/opensync-1.0/opensync/mapping/opensync_mapping_table.h
include/opensync-1.0/opensync/mapping/opensync_mapping_view.h
-include/opensync-1.0/opensync/merger/opensync_capabilities.h
-include/opensync-1.0/opensync/merger/opensync_capability.h
include/opensync-1.0/opensync/merger/opensync_merger.h
-include/opensync-1.0/opensync/merger/opensync_xmlfield.h
+include/opensync-1.0/opensync/merger/opensync_capability.h
+include/opensync-1.0/opensync/merger/opensync_capabilities.h
include/opensync-1.0/opensync/merger/opensync_xmlfieldlist.h
+include/opensync-1.0/opensync/merger/opensync_xmlfield.h
include/opensync-1.0/opensync/merger/opensync_xmlformat.h
+include/opensync-1.0/opensync/plugin/opensync_plugin.h
+include/opensync-1.0/opensync/plugin/opensync_sink.h
+include/opensync-1.0/opensync/plugin/opensync_plugin_env.h
+include/opensync-1.0/opensync/plugin/opensync_plugin_info.h
+include/opensync-1.0/opensync/version/opensync_version.h
+include/opensync-1.0/opensync/opensync.h
include/opensync-1.0/opensync/opensync-archive.h
include/opensync-1.0/opensync/opensync-client.h
include/opensync-1.0/opensync/opensync-context.h
@@ -41,6 +49,7 @@ include/opensync-1.0/opensync/opensync-format.h
include/opensync-1.0/opensync/opensync-group.h
include/opensync-1.0/opensync/opensync-helper.h
include/opensync-1.0/opensync/opensync-ipc.h
+include/opensync-1.0/opensync/opensync_list.h
include/opensync-1.0/opensync/opensync-mapping.h
include/opensync-1.0/opensync/opensync-merger.h
include/opensync-1.0/opensync/opensync-module.h
@@ -49,41 +58,46 @@ include/opensync-1.0/opensync/opensync-serializer.h
include/opensync-1.0/opensync/opensync-support.h
include/opensync-1.0/opensync/opensync-time.h
include/opensync-1.0/opensync/opensync-version.h
-include/opensync-1.0/opensync/opensync.h
-include/opensync-1.0/opensync/opensync_list.h
-include/opensync-1.0/opensync/opensync_xml.h
-include/opensync-1.0/opensync/plugin/opensync_plugin.h
-include/opensync-1.0/opensync/plugin/opensync_plugin_env.h
-include/opensync-1.0/opensync/plugin/opensync_plugin_info.h
-include/opensync-1.0/opensync/plugin/opensync_sink.h
-include/opensync-1.0/opensync/version/opensync_version.h
+include/opensync-1.0/opensync/file.h
lib/libopensync.so
lib/libopensync.so.1
-lib/opensync/formats/libdata.so
-lib/opensync/formats/libfile.so
-lib/opensync/formats/libxmlformat-doc.so
-lib/opensync/formats/libxmlformat.so
+lib/libopensync.so.1.0.0
+lib/opensync-1.0/formats/file.so
+lib/opensync-1.0/formats/plain.so
+lib/opensync-1.0/formats/xmlformat.so
+lib/opensync-1.0/formats/xmlformat-doc.so
+lib/opensync-1.0/osplugin
libdata/pkgconfig/opensync-1.0.pc
-libdata/pkgconfig/osengine-1.0.pc
-share/opensync/capabilities/file-sync.xml
-share/opensync/capabilities/syncml-nokia-7650.xml
-share/opensync/descriptions/miscellaneous.xml
-share/opensync/descriptions/syncml-nokia.xml
-share/opensync/schemas/descriptions.xsd
-share/opensync/schemas/xmlformat-calendar.xsd
-share/opensync/schemas/xmlformat-common.xsd
-share/opensync/schemas/xmlformat-contact.xsd
-share/opensync/schemas/xmlformat-event.xsd
-share/opensync/schemas/xmlformat-note.xsd
-share/opensync/schemas/xmlformat-todo.xsd
-@dirrm share/opensync/schemas
-@dirrm share/opensync/descriptions
-@dirrm share/opensync/capabilities
-@dirrm share/opensync
-@dirrm lib/opensync/formats
-@dirrm lib/opensync
+share/opensync-1.0/capabilities/syncml-nokia-7650.xml
+share/opensync-1.0/capabilities/reference.xml
+share/opensync-1.0/descriptions/syncml-nokia.xml
+share/opensync-1.0/descriptions/reference.xml
+share/opensync-1.0/schemas/xmlformat-contact.xsd
+share/opensync-1.0/schemas/plugin_config.xsd
+share/opensync-1.0/schemas/descriptions.xsd
+share/opensync-1.0/schemas/xmlformat-event.xsd
+share/opensync-1.0/schemas/xmlformat-note.xsd
+share/opensync-1.0/schemas/xmlformat-todo.xsd
+share/opensync-1.0/schemas/xmlformat-common.xsd
+share/opensync-1.0/schemas/xmlformat-calendar.xsd
+share/opensync-1.0/cmake/modules/OpenSyncPlatforms.cmake
+share/opensync-1.0/cmake/modules/OpenSyncPackaging.cmake
+share/opensync-1.0/cmake/modules/OpenSyncTesting.cmake
+share/opensync-1.0/cmake/modules/OpenSyncPlugin.cmake
+share/opensync-1.0/cmake/modules/OpenSyncInternal.cmake
+%%PYTHON_SITELIBDIR%%/_opensync.so
+%%PYTHON_SITELIBDIR%%/opensync.py
+@dirrm share/opensync-1.0/schemas
+@dirrm share/opensync-1.0/descriptions
+@dirrm share/opensync-1.0/cmake/modules
+@dirrm share/opensync-1.0/cmake
+@dirrm share/opensync-1.0/capabilities
+@dirrm share/opensync-1.0
+@dirrmtry lib/opensync-1.0/formats
+@dirrmtry lib/opensync-1.0
@dirrm include/opensync-1.0/opensync/version
@dirrm include/opensync-1.0/opensync/plugin
+@dirrmtry include/opensync-1.0/opensync/module
@dirrm include/opensync-1.0/opensync/merger
@dirrm include/opensync-1.0/opensync/mapping
@dirrm include/opensync-1.0/opensync/ipc
@@ -91,7 +105,9 @@ share/opensync/schemas/xmlformat-todo.xsd
@dirrm include/opensync-1.0/opensync/group
@dirrm include/opensync-1.0/opensync/format
@dirrm include/opensync-1.0/opensync/engine
+@dirrm include/opensync-1.0/opensync/db
@dirrm include/opensync-1.0/opensync/data
+@dirrm include/opensync-1.0/opensync/client
@dirrm include/opensync-1.0/opensync/archive
@dirrm include/opensync-1.0/opensync
@dirrm include/opensync-1.0