aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libshbuf/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-05-06 22:47:14 +0800
committerijliao <ijliao@FreeBSD.org>2002-05-06 22:47:14 +0800
commit8a0adde4e490d6e598fd318ca45042d4ebd9597e (patch)
tree0d4d0c5cb10f5cf1b0a34ae8d8d80f0bb1fd3e8e /devel/libshbuf/Makefile
parent9692dce85585819d35a89d5a600600233bb66281 (diff)
downloadfreebsd-ports-graphics-8a0adde4e490d6e598fd318ca45042d4ebd9597e.tar.gz
freebsd-ports-graphics-8a0adde4e490d6e598fd318ca45042d4ebd9597e.tar.zst
freebsd-ports-graphics-8a0adde4e490d6e598fd318ca45042d4ebd9597e.zip
add libshbuf 0.0.2
Library for Shared Buffer IPC
Diffstat (limited to 'devel/libshbuf/Makefile')
-rw-r--r--devel/libshbuf/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/devel/libshbuf/Makefile b/devel/libshbuf/Makefile
new file mode 100644
index 00000000000..83c092661a3
--- /dev/null
+++ b/devel/libshbuf/Makefile
@@ -0,0 +1,24 @@
+# ex:ts=8
+# Ports collection makefile for: libshbuf
+# Date created: May 6, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libshbuf
+PORTVERSION= 0.0.2
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${PERL} -pi -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
+
+.include <bsd.port.mk>