aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libzrtpcpp/Makefile
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2006-10-07 03:01:59 +0800
committeracm <acm@FreeBSD.org>2006-10-07 03:01:59 +0800
commit7a2d1d303cd30221e676d5d391c7f1bca059f0d7 (patch)
tree6445718c49299836c19d8dc95c633ca0d78d8632 /devel/libzrtpcpp/Makefile
parent9fd456161d17fb94947c04d958d07d6cc1cc1076 (diff)
downloadfreebsd-ports-graphics-7a2d1d303cd30221e676d5d391c7f1bca059f0d7.tar.gz
freebsd-ports-graphics-7a2d1d303cd30221e676d5d391c7f1bca059f0d7.tar.zst
freebsd-ports-graphics-7a2d1d303cd30221e676d5d391c7f1bca059f0d7.zip
- Fix build on 4.x
- Bump PORTREVISION Reported by: kris
Diffstat (limited to 'devel/libzrtpcpp/Makefile')
-rw-r--r--devel/libzrtpcpp/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/devel/libzrtpcpp/Makefile b/devel/libzrtpcpp/Makefile
index b1581e430e6..8e94fe55eff 100644
--- a/devel/libzrtpcpp/Makefile
+++ b/devel/libzrtpcpp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libzrtpcpp
PORTVERSION= 0.9.0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR=ccrtp
@@ -30,6 +31,8 @@ USE_LDCONFIG= yes
post-patch:
@cd ${WRKSRC}/src && \
- ${FIND} * -type f -exec ${REINPLACE_CMD} -i "" -e "s|<malloc.h>|<stdlib.h>|g" "{}" \;
+ ${FIND} * -type f -exec ${REINPLACE_CMD} -i "" -e "s|<malloc.h>|<stdlib.h>|g" "{}" \; && \
+ ${FIND} * -type f -exec ${REINPLACE_CMD} -i "" -e "s|<stdint.h>|<inttypes.h>|g" "{}" \;
+ @${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.mk>