aboutsummaryrefslogtreecommitdiffstats
path: root/devel/lua-posix/Makefile
diff options
context:
space:
mode:
authorphilip <philip@FreeBSD.org>2006-11-02 08:38:06 +0800
committerphilip <philip@FreeBSD.org>2006-11-02 08:38:06 +0800
commit26eef35f8205c7c4b1e5a1ea09632077d7a5f276 (patch)
tree24e9071377d5757bf596368c97765000f3e6a8fd /devel/lua-posix/Makefile
parent34589ece4289187dae27eff03e9ae4c6676149fa (diff)
downloadfreebsd-ports-graphics-26eef35f8205c7c4b1e5a1ea09632077d7a5f276.tar.gz
freebsd-ports-graphics-26eef35f8205c7c4b1e5a1ea09632077d7a5f276.tar.zst
freebsd-ports-graphics-26eef35f8205c7c4b1e5a1ea09632077d7a5f276.zip
Add devel/lua-posix to work with Lua 5.0 and Lua 5.1 and turn devel/lua-posix
into a slave port of it. PR: ports/104990 Submitted by: Andrew Turner <andrew+ports@fubar.geek.nz> (maintainer) Repocopy by: marcus
Diffstat (limited to 'devel/lua-posix/Makefile')
-rw-r--r--devel/lua-posix/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/devel/lua-posix/Makefile b/devel/lua-posix/Makefile
index 37ec1872664..02a45b1d6d8 100644
--- a/devel/lua-posix/Makefile
+++ b/devel/lua-posix/Makefile
@@ -15,12 +15,20 @@ DISTFILES= lposix.tar.gz
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= A POSIX layer for Lua
-USE_LUA= 5.0
+USE_LUA?= 5.1
WRKSRC= ${WRKDIR}/posix
PLIST_FILES= %%LUA_MODSHAREDIR%%/posix.lua \
%%LUA_MODLIBDIR%%/lposix.so
+.if ${USE_LUA} == 5.1
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-51-lposix.c \
+ ${FILESDIR}/extrapatch-51-posix.lua \
+ ${FILESDIR}/extrapatch-51-test.lua
+.elif ${USE_LUA} == 5.0
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-50-Makefile
+.endif
+
do-install:
@${INSTALL_DATA} ${WRKSRC}/posix.lua ${LUA_MODSHAREDIR}
@${INSTALL_PROGRAM} ${WRKSRC}/lposix.so ${LUA_MODLIBDIR}