aboutsummaryrefslogtreecommitdiffstats
path: root/devel/orbitcpp
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-06-20 23:48:49 +0800
committermarcus <marcus@FreeBSD.org>2003-06-20 23:48:49 +0800
commitf1a3793cb129924063649ab8aa41e47f1231db59 (patch)
tree854118480119a43398070182defdb68c43e8c4ea /devel/orbitcpp
parentbf91b71d1e948283d0b9c56f94ab8f32fe3d000f (diff)
downloadfreebsd-ports-graphics-f1a3793cb129924063649ab8aa41e47f1231db59.tar.gz
freebsd-ports-graphics-f1a3793cb129924063649ab8aa41e47f1231db59.tar.zst
freebsd-ports-graphics-f1a3793cb129924063649ab8aa41e47f1231db59.zip
Fix problems with g++-2.9x and virtual interfaces.
Submitted by: Alexander Nedotsukov <bland@mail.ru> Obtained from: Bowie Owens <bowie@owens.csiro.au>
Diffstat (limited to 'devel/orbitcpp')
-rw-r--r--devel/orbitcpp/Makefile2
-rw-r--r--devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types:IDLStruct.h11
-rw-r--r--devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types:IDLUnion.h11
3 files changed, 23 insertions, 1 deletions
diff --git a/devel/orbitcpp/Makefile b/devel/orbitcpp/Makefile
index 1736494ac11..62a76eefee7 100644
--- a/devel/orbitcpp/Makefile
+++ b/devel/orbitcpp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= orbitcpp
PORTVERSION= 1.3.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
diff --git a/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types:IDLStruct.h b/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types:IDLStruct.h
new file mode 100644
index 00000000000..d0579b763c4
--- /dev/null
+++ b/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types:IDLStruct.h
@@ -0,0 +1,11 @@
+--- orbitcpp/idl-compiler/types/IDLStruct.h.orig Fri Jun 20 14:36:07 2003
++++ orbitcpp/idl-compiler/types/IDLStruct.h Fri Jun 20 14:36:26 2003
+@@ -33,7 +33,7 @@
+ #include "IDLCompound.h"
+ #include "IDLCompoundSeqElem.h"
+
+-class IDLStruct: public IDLCompound, public virtual IDLType, public IDLCompoundSeqElem
++class IDLStruct: public IDLCompound, public IDLCompoundSeqElem
+ {
+ public:
+ IDLStruct(const string &id,
diff --git a/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types:IDLUnion.h b/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types:IDLUnion.h
new file mode 100644
index 00000000000..5de45d00b4c
--- /dev/null
+++ b/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types:IDLUnion.h
@@ -0,0 +1,11 @@
+--- orbitcpp/idl-compiler/types/IDLUnion.h.orig Fri Jun 20 15:05:07 2003
++++ orbitcpp/idl-compiler/types/IDLUnion.h Fri Jun 20 15:05:33 2003
+@@ -34,7 +34,7 @@
+ #include "IDLCompoundSeqElem.h"
+ //#include "language.h"
+
+-class IDLUnion: public virtual IDLType, public IDLScope, public IDLCompoundSeqElem
++class IDLUnion: public IDLScope, public IDLCompoundSeqElem
+ {
+ const IDLUnionDiscriminator &m_discriminator;
+