aboutsummaryrefslogtreecommitdiffstats
path: root/devel/orc
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2010-03-09 18:55:47 +0800
committermm <mm@FreeBSD.org>2010-03-09 18:55:47 +0800
commitb0a60f46a4ecc6138c028d79249c2da671e5e265 (patch)
tree54c2fb846f198d3849c67950795cbcf20763ffc1 /devel/orc
parent4366eaa0020af78008e50442877bc4655cbe28fc (diff)
downloadfreebsd-ports-graphics-b0a60f46a4ecc6138c028d79249c2da671e5e265.tar.gz
freebsd-ports-graphics-b0a60f46a4ecc6138c028d79249c2da671e5e265.tar.zst
freebsd-ports-graphics-b0a60f46a4ecc6138c028d79249c2da671e5e265.zip
Orc – The Oil Runtime Compiler
Orc is a library and set of tools for compiling and executing very simple programs that operate on arrays of data. The "language" is a generic assembly language that represents many of the features available in SIMD architectures, including saturated addition and subtraction, and many arithmetic operations. (OIL stands for Optimized Inner Loops) WWW: http://code.entropywave.com/projects/orc/
Diffstat (limited to 'devel/orc')
-rw-r--r--devel/orc/Makefile42
-rw-r--r--devel/orc/distinfo3
-rw-r--r--devel/orc/pkg-descr7
-rw-r--r--devel/orc/pkg-plist82
4 files changed, 134 insertions, 0 deletions
diff --git a/devel/orc/Makefile b/devel/orc/Makefile
new file mode 100644
index 00000000000..498c498e65f
--- /dev/null
+++ b/devel/orc/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: orc
+# Date created: Mar 09, 2010
+# Whom: mm
+#
+# $FreeBSD$
+
+PORTNAME= orc
+PORTVERSION= 0.4.3
+CATEGORIES= devel
+MASTER_SITES= http://code.entropywave.com/download/orc/
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= Library and toolset to operate arrays of data
+
+USE_GNOME= pkgconfig
+USE_AUTOTOOLS= libtool:22
+USE_LDCONFIG= yes
+
+CONFIGURE_ARGS+= --disable-gtk-doc
+
+SUBDIRS= orc orc-float orc-pixel orc-test tools
+
+OPTIONS= DOCS "Include gtk-doc documentation" off \
+ EXAMPLES "Install example files" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DOCS) && !defined(NOPORTDOCS)
+SUBDIRS+= doc
+.else
+NOPORTDOCS= yes
+.endif
+
+.if defined(WITH_EXAMPLES) && !defined(NOPORTEXAMPLES)
+SUBDIRS+= examples
+.else
+NOPORTEXAMPLES= yes
+.endif
+
+MAKE_ARGS+= SUBDIRS="${SUBDIRS}"
+
+.include <bsd.port.post.mk>
diff --git a/devel/orc/distinfo b/devel/orc/distinfo
new file mode 100644
index 00000000000..10f54c648b4
--- /dev/null
+++ b/devel/orc/distinfo
@@ -0,0 +1,3 @@
+MD5 (orc-0.4.3.tar.gz) = 9b2e7030c8df8a0d371115869fe5685a
+SHA256 (orc-0.4.3.tar.gz) = 4c0266d81da67fef0b2abd5e624a9ab0db5de04eb23c3ab24e22f5f9ceeefbfe
+SIZE (orc-0.4.3.tar.gz) = 538428
diff --git a/devel/orc/pkg-descr b/devel/orc/pkg-descr
new file mode 100644
index 00000000000..b9a7a377fed
--- /dev/null
+++ b/devel/orc/pkg-descr
@@ -0,0 +1,7 @@
+Orc is a library and set of tools for compiling and executing very simple
+programs that operate on arrays of data. The "language" is a generic
+assembly language that represents many of the features available in SIMD
+architectures, including saturated addition and subtraction, and many
+arithmetic operations.
+
+WWW: http://code.entropywave.com/projects/orc/
diff --git a/devel/orc/pkg-plist b/devel/orc/pkg-plist
new file mode 100644
index 00000000000..6adf5569fd4
--- /dev/null
+++ b/devel/orc/pkg-plist
@@ -0,0 +1,82 @@
+bin/orcc
+include/orc-0.4/orc-float/orcfloat.h
+include/orc-0.4/orc-pixel/orcpixel.h
+include/orc-0.4/orc-test/orcarray.h
+include/orc-0.4/orc-test/orcprofile.h
+include/orc-0.4/orc-test/orcrandom.h
+include/orc-0.4/orc-test/orctest.h
+include/orc-0.4/orc/opcodes.h
+include/orc-0.4/orc/orc-stdint.h
+include/orc-0.4/orc/orc.h
+include/orc-0.4/orc/orcarm.h
+include/orc-0.4/orc/orcdebug.h
+include/orc-0.4/orc/orcfunctions.h
+include/orc-0.4/orc/orcmmx.h
+include/orc-0.4/orc/orconce.h
+include/orc-0.4/orc/orcparse.h
+include/orc-0.4/orc/orcpowerpc.h
+include/orc-0.4/orc/orcprogram.h
+include/orc-0.4/orc/orcsse.h
+include/orc-0.4/orc/orcutils.h
+include/orc-0.4/orc/orcx86.h
+lib/liborc-0.4.a
+lib/liborc-0.4.la
+lib/liborc-0.4.so
+lib/liborc-0.4.so.0
+lib/liborc-float-0.4.a
+lib/liborc-float-0.4.la
+lib/liborc-float-0.4.so
+lib/liborc-float-0.4.so.0
+lib/liborc-pixel-0.4.a
+lib/liborc-pixel-0.4.la
+lib/liborc-pixel-0.4.so
+lib/liborc-pixel-0.4.so.0
+lib/liborc-test-0.4.a
+lib/liborc-test-0.4.la
+lib/liborc-test-0.4.so
+lib/liborc-test-0.4.so.0
+%%PORTEXAMPLES%%lib/orc/example1
+%%PORTEXAMPLES%%lib/orc/mt19937ar
+%%PORTEXAMPLES%%lib/orc/volscale
+lib/pkgconfig/orc-0.4.pc
+%%PORTDOCS%%share/gtk-doc/html/orc/ch01.html
+%%PORTDOCS%%share/gtk-doc/html/orc/ch02.html
+%%PORTDOCS%%share/gtk-doc/html/orc/ch03.html
+%%PORTDOCS%%share/gtk-doc/html/orc/ch04.html
+%%PORTDOCS%%share/gtk-doc/html/orc/ch05.html
+%%PORTDOCS%%share/gtk-doc/html/orc/home.png
+%%PORTDOCS%%share/gtk-doc/html/orc/index.html
+%%PORTDOCS%%share/gtk-doc/html/orc/index.sgml
+%%PORTDOCS%%share/gtk-doc/html/orc/left.png
+%%PORTDOCS%%share/gtk-doc/html/orc/orc-building.html
+%%PORTDOCS%%share/gtk-doc/html/orc/orc-concepts.html
+%%PORTDOCS%%share/gtk-doc/html/orc/orc-misc.html
+%%PORTDOCS%%share/gtk-doc/html/orc/orc-opcodes.html
+%%PORTDOCS%%share/gtk-doc/html/orc/orc-orc.html
+%%PORTDOCS%%share/gtk-doc/html/orc/orc-orcarm.html
+%%PORTDOCS%%share/gtk-doc/html/orc/orc-orccompiler.html
+%%PORTDOCS%%share/gtk-doc/html/orc/orc-orcdebug.html
+%%PORTDOCS%%share/gtk-doc/html/orc/orc-orcexecutor.html
+%%PORTDOCS%%share/gtk-doc/html/orc/orc-orcmmx.html
+%%PORTDOCS%%share/gtk-doc/html/orc/orc-orcopcode.html
+%%PORTDOCS%%share/gtk-doc/html/orc/orc-orcpowerpc.html
+%%PORTDOCS%%share/gtk-doc/html/orc/orc-orcprogram.html
+%%PORTDOCS%%share/gtk-doc/html/orc/orc-orcrule.html
+%%PORTDOCS%%share/gtk-doc/html/orc/orc-orcsse.html
+%%PORTDOCS%%share/gtk-doc/html/orc/orc-orcutils.html
+%%PORTDOCS%%share/gtk-doc/html/orc/orc-orcx86.html
+%%PORTDOCS%%share/gtk-doc/html/orc/orc.devhelp
+%%PORTDOCS%%share/gtk-doc/html/orc/orc.devhelp2
+%%PORTDOCS%%share/gtk-doc/html/orc/right.png
+%%PORTDOCS%%share/gtk-doc/html/orc/style.css
+%%PORTDOCS%%share/gtk-doc/html/orc/up.png
+@dirrmtry lib/pkgconfig
+@dirrm include/orc-0.4/orc
+@dirrm include/orc-0.4/orc-float
+@dirrm include/orc-0.4/orc-pixel
+@dirrm include/orc-0.4/orc-test
+@dirrm include/orc-0.4
+%%PORTEXAMPLES%%@dirrm lib/orc
+%%PORTDOCS%%@dirrm share/gtk-doc/html/orc
+%%PORTDOCS%%@dirrmtry share/gtk-doc/html
+%%PORTDOCS%%@dirrmtry share/gtk-doc