aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-App-Info/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2003-05-19 14:54:10 +0800
committerdemon <demon@FreeBSD.org>2003-05-19 14:54:10 +0800
commit865f71a26729480816f8a806554412ab4116ac63 (patch)
treedf3f622f1c8768a7243cb1b422e048650ab228b3 /devel/p5-App-Info/Makefile
parent56ba9435fe7ef09c202e8332f9812ee534c2d462 (diff)
downloadfreebsd-ports-graphics-865f71a26729480816f8a806554412ab4116ac63.tar.gz
freebsd-ports-graphics-865f71a26729480816f8a806554412ab4116ac63.tar.zst
freebsd-ports-graphics-865f71a26729480816f8a806554412ab4116ac63.zip
New port -- p5-App-Info:
Interface for providing metadata about installed software packages.
Diffstat (limited to 'devel/p5-App-Info/Makefile')
-rw-r--r--devel/p5-App-Info/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/p5-App-Info/Makefile b/devel/p5-App-Info/Makefile
new file mode 100644
index 00000000000..b27ee5d1655
--- /dev/null
+++ b/devel/p5-App-Info/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-App-Info
+# Date created: 19 May 2003
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= App-Info
+PORTVERSION= 0.23
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= App
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Interface for providing metadata about installed software packages
+
+BUILD_DEPENDS= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
+ ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple
+
+PERL_CONFIGURE= YES
+
+MAN3= App::Info::HTTPD.3 App::Info::Lib::Iconv.3 \
+ App::Info::HTTPD::Apache.3 App::Info::Lib.3 App::Info::RDBMS.3 \
+ App::Info::Lib::Expat.3 App::Info::Request.3 \
+ App::Info::Handler::Print.3 App::Info::RDBMS::PostgreSQL.3 \
+ App::Info::Util.3 App::Info::Handler.3 App::Info.3 \
+ App::Info::Handler::Prompt.3 App::Info::Handler::Carp.3
+
+.include <bsd.port.mk>