aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-IPC-Cache
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-05-09 09:20:36 +0800
committeredwin <edwin@FreeBSD.org>2003-05-09 09:20:36 +0800
commit967abb004a55ef99a484e63e5beee2251ba83f16 (patch)
tree196a453d61ed7b44da7c89a706d29aba9a7233fa /devel/p5-IPC-Cache
parent43d05575f8ba782e5e6ee2841401677186418eda (diff)
downloadfreebsd-ports-graphics-967abb004a55ef99a484e63e5beee2251ba83f16.tar.gz
freebsd-ports-graphics-967abb004a55ef99a484e63e5beee2251ba83f16.tar.zst
freebsd-ports-graphics-967abb004a55ef99a484e63e5beee2251ba83f16.zip
iconditionalize dependencies on modules included in perl 5.8
Make dependencies on modules included in the perl 5.8 distribution conditional on the perl version installed. While I'm here, remove SITE_PERL and MAN(3)PREFIX. These patches only include unmaintained ports. PR: ports/50589 Submitted by: Erwin Lansing <erwin@lansing.dk>
Diffstat (limited to 'devel/p5-IPC-Cache')
-rw-r--r--devel/p5-IPC-Cache/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/devel/p5-IPC-Cache/Makefile b/devel/p5-IPC-Cache/Makefile
index ebb212c9164..69edf60a352 100644
--- a/devel/p5-IPC-Cache/Makefile
+++ b/devel/p5-IPC-Cache/Makefile
@@ -15,13 +15,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Persist data across processes via shared memory
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/IPC/ShareLite.pm:${PORTSDIR}/devel/p5-IPC-ShareLite \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/IPC/ShareLite.pm:${PORTSDIR}/devel/p5-IPC-ShareLite
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= IPC::Cache.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+.endif
+
+.include <bsd.port.post.mk>