aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-POE-Component-RSSAggregator
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-08-01 15:16:45 +0800
committerclsung <clsung@FreeBSD.org>2006-08-01 15:16:45 +0800
commite30f6669ceee23b9ba5951329bc15674e7a46a35 (patch)
tree5a0145a3fcc43edfeb335d424974c1635d7d5f3c /devel/p5-POE-Component-RSSAggregator
parent89018333d96b485a400ceafaf2ddba5186512353 (diff)
downloadfreebsd-ports-graphics-e30f6669ceee23b9ba5951329bc15674e7a46a35.tar.gz
freebsd-ports-graphics-e30f6669ceee23b9ba5951329bc15674e7a46a35.tar.zst
freebsd-ports-graphics-e30f6669ceee23b9ba5951329bc15674e7a46a35.zip
- p5-POE-Component-RSSAggregator provide
Watch Muliple RSS Feeds for New Headlines - a non-blocking way to watch multiple RSS sources with one process
Diffstat (limited to 'devel/p5-POE-Component-RSSAggregator')
-rw-r--r--devel/p5-POE-Component-RSSAggregator/Makefile34
-rw-r--r--devel/p5-POE-Component-RSSAggregator/distinfo3
-rw-r--r--devel/p5-POE-Component-RSSAggregator/pkg-descr6
-rw-r--r--devel/p5-POE-Component-RSSAggregator/pkg-plist7
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/p5-POE-Component-RSSAggregator/Makefile b/devel/p5-POE-Component-RSSAggregator/Makefile
new file mode 100644
index 00000000000..b95793e8898
--- /dev/null
+++ b/devel/p5-POE-Component-RSSAggregator/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: POE-Component-RSSAggregator
+# Date created: Aug 1, 2006
+# Whom: Cheng-Lung Sung
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-RSSAggregator
+PORTVERSION= 1.01
+CATEGORIES= devel perl5 textproc
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Watch Muliple RSS Feeds for New Headlines
+
+BUILD_DEPENDS= ${SITE_PERL}/HTTP/Request.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/XML/RSS/Feed.pm:${PORTSDIR}/textproc/p5-XML-RSS-Feed \
+ p5-POE-Component-Client-DNS>=0.98:${PORTSDIR}/dns/p5-POE-Component-Client-DNS \
+ p5-POE-Component-Client-HTTP>=0.51:${PORTSDIR}/www/p5-POE-Component-Client-HTTP
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::RSSAggregator.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-POE-Component-RSSAggregator/distinfo b/devel/p5-POE-Component-RSSAggregator/distinfo
new file mode 100644
index 00000000000..b6544626e91
--- /dev/null
+++ b/devel/p5-POE-Component-RSSAggregator/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Component-RSSAggregator-1.01.tar.gz) = c5d3283587a8e82dbd73f725cd9c5779
+SHA256 (POE-Component-RSSAggregator-1.01.tar.gz) = 4d7b4ee0a5df8c8cbb80bdc661a041c8587dc072d464d99910f2227c00f79923
+SIZE (POE-Component-RSSAggregator-1.01.tar.gz) = 7618
diff --git a/devel/p5-POE-Component-RSSAggregator/pkg-descr b/devel/p5-POE-Component-RSSAggregator/pkg-descr
new file mode 100644
index 00000000000..bfe23255b4a
--- /dev/null
+++ b/devel/p5-POE-Component-RSSAggregator/pkg-descr
@@ -0,0 +1,6 @@
+POW::Component::RSSAggregator is a non-blocking way to watch
+multiple RSS sources with one process.
+
+See also p5-XML-RSS-Feed.
+
+WWW: http://search.cpan.org/dist/POE-Component-RSSAggregator/
diff --git a/devel/p5-POE-Component-RSSAggregator/pkg-plist b/devel/p5-POE-Component-RSSAggregator/pkg-plist
new file mode 100644
index 00000000000..e2a8f68903f
--- /dev/null
+++ b/devel/p5-POE-Component-RSSAggregator/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/POE/Component/RSSAggregator.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/RSSAggregator/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/RSSAggregator
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/POE/Component
+@dirrmtry %%SITE_PERL%%/POE