aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Test-Inline
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-04-13 20:28:23 +0800
committeredwin <edwin@FreeBSD.org>2003-04-13 20:28:23 +0800
commit48a241b76eec811abc57f7b6cb09e19340fc862c (patch)
treede759967af3bbf8379751e686f131f856622d20e /devel/p5-Test-Inline
parent1f26dd33c2e40b49947e66b88565d60ed8c823d6 (diff)
downloadfreebsd-ports-graphics-48a241b76eec811abc57f7b6cb09e19340fc862c.tar.gz
freebsd-ports-graphics-48a241b76eec811abc57f7b6cb09e19340fc862c.tar.zst
freebsd-ports-graphics-48a241b76eec811abc57f7b6cb09e19340fc862c.zip
Conditionalize dependencies for moudules included in perl 5.8
Make dependencies on modules included in the perl 5.8 distribution conditional on the perl version installed. While I'm here, remove SITE_PERL and MAN(3)PREFIX. 17 + 29 + 234 = 280 PRs. It's about time he starts doing the work himself! PR: ports/50588 Submitted by: Erwin Lansing <erwin@lansing.dk>
Diffstat (limited to 'devel/p5-Test-Inline')
-rw-r--r--devel/p5-Test-Inline/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/devel/p5-Test-Inline/Makefile b/devel/p5-Test-Inline/Makefile
index de0c460046a..176aa927999 100644
--- a/devel/p5-Test-Inline/Makefile
+++ b/devel/p5-Test-Inline/Makefile
@@ -15,23 +15,24 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
COMMENT= Test::Inline - Inlining your tests next to the code being tested
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Harness.pm:${PORTSDIR}/devel/p5-Test-Harness \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Harness.pm:${PORTSDIR}/devel/p5-Test-Harness
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN1= pod2test.1
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Pod::Tests.3 Pod::Tests::Tutorial.3 Test::Inline.3 Test::Inline::Tutorial.3
.include <bsd.port.pre.mk>
-SITE_PERL?= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
-
.if ${PERL_LEVEL} < 500601
BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
.endif
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
.include <bsd.port.post.mk>