aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pccts/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1997-07-01 15:48:26 +0800
committertg <tg@FreeBSD.org>1997-07-01 15:48:26 +0800
commit59ef59db34b0d65a3b526b76790012e410242986 (patch)
tree17758905b6912b1006aecf1fdb8db22ecb2ba4e1 /devel/pccts/Makefile
parent7a14418f93f798f8556f9be343e7db26b5ce89d4 (diff)
downloadfreebsd-ports-graphics-59ef59db34b0d65a3b526b76790012e410242986.tar.gz
freebsd-ports-graphics-59ef59db34b0d65a3b526b76790012e410242986.tar.zst
freebsd-ports-graphics-59ef59db34b0d65a3b526b76790012e410242986.zip
Import a port of The Purdue Compiler Construction Tool Set.
PR: 3950 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Diffstat (limited to 'devel/pccts/Makefile')
-rw-r--r--devel/pccts/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/devel/pccts/Makefile b/devel/pccts/Makefile
new file mode 100644
index 00000000000..78416aee37f
--- /dev/null
+++ b/devel/pccts/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: pccts
+# Version required: 1.33
+# Date created: 22 June 1997
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= pccts
+PKGNAME= pccts-1.33
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.parr-research.com/pub/pccts/1.33/
+
+MAINTAINER= andy@icc.surw.chel.su
+
+MAKEFILE= makefile
+ALL_TARGET=
+MAN1= antlr.1 dlg.1 pccts.1
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/antlr ${PREFIX}/bin/antlr
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/dlg ${PREFIX}/bin/dlg
+.for file in pccts antlr/antlr dlg/dlg
+ @ ${INSTALL_MAN} ${WRKSRC}/${file}.1 ${PREFIX}/man/man1
+.endfor
+ @ ${MKDIR} ${PREFIX}/include/pccts
+.for file in ast charptr
+ @ ${INSTALL_DATA} ${WRKSRC}/h/${file}.c ${PREFIX}/include/pccts/${file}.c
+.endfor
+.for file in AParser ASTBase ATokPtr ATokenBuffer DLexer DLexerBase PCCTSAST SList
+ @ ${INSTALL_DATA} ${WRKSRC}/h/${file}.cpp ${PREFIX}/include/pccts/${file}.cpp
+.endfor
+.for file in AParser ASTBase ATokPtr AToken ATokenBuffer ATokenStream DLexerBase PBlackBox PCCTSAST SList antlr ast charbuf charptr config dlgauto dlgdef err int
+ @ ${INSTALL_DATA} ${WRKSRC}/h/${file}.h ${PREFIX}/include/pccts/${file}.h
+.endfor
+ @ ${MKDIR} ${PREFIX}/share/doc/pccts
+.for file in BOOK README RIGHTS SERVICES history.ps history.txt
+ @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/pccts/${file}
+.endfor
+ @ ${MKDIR} ${PREFIX}/share/examples/pccts
+.for dir in 1 2 3 4 5 6 6/A 6/B 7 8 9 10 11 12 13
+ @ ${MKDIR} ${PREFIX}/share/examples/pccts/${dir}
+.endfor
+.for file in makefile 1/makefile 1/test.g 2/MyLexer.cpp 2/MyLexer.h 2/makefile 2/test.g 3/MyLexer.cpp 3/MyLexer.h 3/makefile 3/mytokens.h 3/test.g 4/makefile 4/mytokens.h 4/test.g 5/input.h 5/makefile 5/test.g 6/file1 6/file2 6/main.cpp 6/makefile 6/makefile2 6/test.g 6/test2.g 7/makefile 7/test.g 8/main.cpp 8/makefile 8/test.g 9/makefile 9/test.g 10/makefile 10/test.g 11/input.h 11/makefile 11/test.g 12/makefile 12/test.g 13/makefile 13/test.g
+ @ ${INSTALL_DATA} ${WRKSRC}/testcpp/${file} ${PREFIX}/share/examples/pccts/${file}
+.endfor
+
+.include <bsd.port.mk>