aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pear-PEAR
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-06-08 07:00:46 +0800
committernork <nork@FreeBSD.org>2003-06-08 07:00:46 +0800
commit745d211ff042f4470c9df0ffe9f99c37920b85c7 (patch)
tree6d423271cde50294359b8b859c4d8d7b1a45c6ae /devel/pear-PEAR
parentc81d0eb89c8cdf6ad9ff097db9f1413450c7dd94 (diff)
downloadfreebsd-ports-graphics-745d211ff042f4470c9df0ffe9f99c37920b85c7.tar.gz
freebsd-ports-graphics-745d211ff042f4470c9df0ffe9f99c37920b85c7.tar.zst
freebsd-ports-graphics-745d211ff042f4470c9df0ffe9f99c37920b85c7.zip
Update to pear-Archive_Tar 1.1.
Update to pear-PEAR 1.1. Update to pear-HTML_Common 1.2. Update to pear-Net_SMTP 1.2.3. Update to pear-Log 1.6.5. Update to pear-I18N 0.8.5. Update to pear 4.3.2. Adapt following ports for pear-PEAR's Makefile.common. pear-Console_Getopt, pear-Auth, pear-Auth_SASL, devel/pear-Date, net/pear-Net_Socket, pear-Mail_Mime, pear-Crypt_CBC, pear-mailparse, pear-File, pear-HTML_Select_Common, and pear-Net_Sieve PR: ports/52596, ports/52641, ports/52655, ports/52656, ports/52671, ports/52678, ports/52845 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'devel/pear-PEAR')
-rw-r--r--devel/pear-PEAR/Makefile30
-rw-r--r--devel/pear-PEAR/Makefile.common43
-rw-r--r--devel/pear-PEAR/distinfo2
-rw-r--r--devel/pear-PEAR/pkg-deinstall13
-rw-r--r--devel/pear-PEAR/pkg-install14
-rw-r--r--devel/pear-PEAR/pkg-plist13
6 files changed, 79 insertions, 36 deletions
diff --git a/devel/pear-PEAR/Makefile b/devel/pear-PEAR/Makefile
index 3243fc37078..dfe74d283ae 100644
--- a/devel/pear-PEAR/Makefile
+++ b/devel/pear-PEAR/Makefile
@@ -6,47 +6,25 @@
#
PORTNAME= PEAR
-PORTVERSION= 1.0.1
-PORTREVISION= 2
+PORTVERSION= 1.1
CATEGORIES= devel www
-MASTER_SITES= http://pear.php.net/get/
-PKGNAMEPREFIX= pear-
-EXTRACT_SUFX= .tgz
-DIST_SUBDIR= PEAR
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR Base System
-BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+BUILD_DEPENDS= ${PEARDIR}/Archive/Tar.php:${PORTSDIR}/archivers/pear-Archive_Tar \
+ ${PEARDIR}/Console/Getopt.php:${PORTSDIR}/devel/pear-Console_Getopt
RUN_DEPENDS= ${BUILD_DEPENDS}
-NO_BUILD= yes
-
.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
-.if exists(${LOCALBASE}/bin/php-config)
-PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
-.else
-PHP_BASE= ${LOCALBASE}
-.endif
-PEAR= ${LOCALBASE}/bin/pear
-LPHP_LIB= lib/php
-PEARDIR= ${PHP_BASE}/${LPHP_LIB}
-PLIST_SUB= PEARDIR=${LPHP_LIB}
MANIFEST= OS PEAR PEAR.php System.php package.dtd scripts template.spec
-TOBACKUP= OS PEAR PEAR.php System.php
do-install:
-.for FILE in ${TOBACKUP}
- @${MV} ${PEARDIR}/${FILE} ${PEARDIR}/${FILE}.dist
-.endfor
@${CP} -Rp ${WRKSRC}/* ${PEARDIR}
.for FILE in ${MANIFEST}
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/${FILE}
.endfor
-post-install:
-# Register an upgraded package
- @${PEAR} upgrade -r -f ${WRKDIR}/package.xml
-
.include <bsd.port.post.mk>
diff --git a/devel/pear-PEAR/Makefile.common b/devel/pear-PEAR/Makefile.common
new file mode 100644
index 00000000000..d229ae24032
--- /dev/null
+++ b/devel/pear-PEAR/Makefile.common
@@ -0,0 +1,43 @@
+# $FreeBSD$
+
+# Common code for pear- ports.
+
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+NO_BUILD= yes
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.else
+PHP_BASE= ${LOCALBASE}
+.endif
+LPEARDIR= share/pear
+PEARDIR= ${PHP_BASE}/${LPEARDIR}
+LPKGREGDIR= ${LPEARDIR}/packages/${PKGNAME}
+PKGREGDIR= ${PHP_BASE}/${LPKGREGDIR}
+PLIST_SUB= PEARDIR=${LPEARDIR} PKGREGDIR=${LPKGREGDIR}
+PKGINSTALL= ${.CURDIR}/../../devel/pear-PEAR/pkg-install
+PKGDEINSTALL= ${.CURDIR}/../../devel/pear-PEAR/pkg-deinstall
+
+DOCSDIR= ${PEARDIR}/docs/${PORTNAME}
+
+pre-install:
+.if exists(${LOCALBASE}/lib/php.DIST_PHP) \
+ || exists(${PHP_BASE}/lib/php.DIST_PHP) \
+ || exists(${LOCALBASE}/.PEAR.pkg) \
+ || exists(${PHP_BASE}/.PEAR.pkg)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " Sorry, the PEAR structure has been modified;"
+ @${ECHO_MSG} " Please deinstall your installed pear- ports."
+ @${ECHO_MSG} ""
+ @${FALSE}
+.endif
+
+post-install:
+ @${MKDIR} ${PKGREGDIR}
+ @${INSTALL_DATA} ${WRKDIR}/package.xml ${PKGREGDIR}
+ @${SETENV} PKG_PREFIX=${PREFIX} \
+ ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/devel/pear-PEAR/distinfo b/devel/pear-PEAR/distinfo
index b09b8d04d70..92e91415c6f 100644
--- a/devel/pear-PEAR/distinfo
+++ b/devel/pear-PEAR/distinfo
@@ -1 +1 @@
-MD5 (PEAR/PEAR-1.0.1.tgz) = 4afa614e25f9df1a79a59f006f9d1ed6
+MD5 (PEAR/PEAR-1.1.tgz) = 2f0703f60361867c7ef613464d1d8f12
diff --git a/devel/pear-PEAR/pkg-deinstall b/devel/pear-PEAR/pkg-deinstall
new file mode 100644
index 00000000000..79df94e800f
--- /dev/null
+++ b/devel/pear-PEAR/pkg-deinstall
@@ -0,0 +1,13 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Remove package declaration from PEAR's registry.
+
+if [ x$2 != xDEINSTALL ]; then
+ exit
+fi
+PKG_NAME=${1%%-[0-9._]*}
+PACKAGE=$(echo $PKG_NAME | sed 's/pear-//')
+
+${PKG_PREFIX}/bin/pear uninstall -r -n ${PACKAGE} || true
diff --git a/devel/pear-PEAR/pkg-install b/devel/pear-PEAR/pkg-install
new file mode 100644
index 00000000000..f622fdfce65
--- /dev/null
+++ b/devel/pear-PEAR/pkg-install
@@ -0,0 +1,14 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Register the package $1 in the port registry
+
+PREFIX=${PKG_PREFIX:-/usr/local}
+PEAR=${PREFIX}/bin/pear
+PKGREGDIR=${PREFIX}/share/pear/packages/$1
+
+[ "x$1" = "x" ] && exit 1
+if [ "x$2" = "xPOST-INSTALL" ]; then
+ ${PEAR} install -r -f ${PKGREGDIR}/package.xml
+fi
diff --git a/devel/pear-PEAR/pkg-plist b/devel/pear-PEAR/pkg-plist
index c66aba50d94..6fe2df7e55b 100644
--- a/devel/pear-PEAR/pkg-plist
+++ b/devel/pear-PEAR/pkg-plist
@@ -1,7 +1,3 @@
-@exec mv %D/lib/php/OS %D/lib/php/OS.dist
-@exec mv %D/lib/php/PEAR %D/lib/php/PEAR.dist
-@exec mv %D/lib/php/PEAR.php %D/lib/php/PEAR.php.dist
-@exec mv %D/lib/php/System.php %D/lib/php/System.php.dist
%%PEARDIR%%/package.dtd
%%PEARDIR%%/template.spec
%%PEARDIR%%/PEAR.php
@@ -26,14 +22,13 @@
%%PEARDIR%%/PEAR/Packager.php
%%PEARDIR%%/PEAR/Registry.php
%%PEARDIR%%/PEAR/Remote.php
-%%PEARDIR%%/scripts/pear.in
%%PEARDIR%%/scripts/pear.bat
+%%PEARDIR%%/scripts/pear.sh
+%%PEARDIR%%/scripts/pearcmd.php
+%%PKGREGDIR%%/package.xml
@dirrm %%PEARDIR%%/OS
@dirrm %%PEARDIR%%/PEAR/Command
@dirrm %%PEARDIR%%/PEAR/Frontend
@dirrm %%PEARDIR%%/PEAR
@dirrm %%PEARDIR%%/scripts
-@unexec mv %D/lib/php/OS.dist %D/lib/php/OS || true
-@unexec mv %D/lib/php/PEAR.dist %D/lib/php/PEAR || true
-@unexec mv %D/lib/php/PEAR.php.dist %D/lib/php/PEAR.php || true
-@unexec mv %D/lib/php/System.php.dist %D/lib/php/System.php || true
+@dirrm %%PKGREGDIR%%