aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pear-PEAR
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-02-24 13:27:41 +0800
committeredwin <edwin@FreeBSD.org>2003-02-24 13:27:41 +0800
commitdb62b47fa4214e30a42fe7615d788fd394634bb5 (patch)
treedfcae2d367617bc3d346263639d3aeee26bc545a /devel/pear-PEAR
parent5eeaa5840923c17a01e19598913ae6928e46ba4b (diff)
downloadfreebsd-ports-graphics-db62b47fa4214e30a42fe7615d788fd394634bb5.tar.gz
freebsd-ports-graphics-db62b47fa4214e30a42fe7615d788fd394634bb5.tar.zst
freebsd-ports-graphics-db62b47fa4214e30a42fe7615d788fd394634bb5.zip
PEAR ports: handling PEAR's registry.
PEAR uses a "registry" to register installed modules, and this registry is initialized during the installation of mod_php4 (since 4.3.0). Unfortunately, installing PEAR modules through the ports does not maintain this registry. This PR fix this problem for the following ports: - sysutils/pear-Log - devel/pear-PEAR - devel/pear-Date - devel/pear-I18N - devel/pear-HTML_Common - devel/pear-HTML_Select_Common - security/pear-Crypt_CBC - mail/pear-Mail_Mime - net/pear-Net_Sieve - sysutils/pear-File - archivers/pear-Archive_Tar PR: ports/47921 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'devel/pear-PEAR')
-rw-r--r--devel/pear-PEAR/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/pear-PEAR/Makefile b/devel/pear-PEAR/Makefile
index 9b64f62c16c..923e82aed9f 100644
--- a/devel/pear-PEAR/Makefile
+++ b/devel/pear-PEAR/Makefile
@@ -7,7 +7,7 @@
PORTNAME= PEAR
PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel www
MASTER_SITES= http://pear.php.net/get/
PKGNAMEPREFIX= pear-
@@ -26,7 +26,10 @@ NO_BUILD= yes
.if exists(${LOCALBASE}/bin/php-config)
PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.else
+PHP_BASE!= ${LOCALBASE}
.endif
+PEAR= ${LOCALBASE}/bin/pear
LPHP_LIB= lib/php
PEARDIR= ${PHP_BASE}/${LPHP_LIB}
PLIST_SUB= PEARDIR=${LPHP_LIB}
@@ -42,4 +45,8 @@ do-install:
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/${FILE}
.endfor
+post-install:
+# Register an upgraded package
+ @${PEAR} upgrade -r -f ${WRKDIR}/package.xml
+
.include <bsd.port.post.mk>