aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pharmacy/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-16 04:37:04 +0800
committermarcus <marcus@FreeBSD.org>2003-11-16 04:37:04 +0800
commit71ad4933995cc892d62e378ee5be6ac15c6e62ef (patch)
tree610711606eefa728d01e4e333cc0119ea924f1f6 /devel/pharmacy/Makefile
parent8918e3de46086cf18a356130171394cc05affdc3 (diff)
downloadfreebsd-ports-graphics-71ad4933995cc892d62e378ee5be6ac15c6e62ef.tar.gz
freebsd-ports-graphics-71ad4933995cc892d62e378ee5be6ac15c6e62ef.tar.zst
freebsd-ports-graphics-71ad4933995cc892d62e378ee5be6ac15c6e62ef.zip
unPERLify, and use ${FIND} and ${XARGS} where appropriate.
PR: 48253 Submitted by: Simon 'portlint' Schubert <corecode@corecode.ath.cx>
Diffstat (limited to 'devel/pharmacy/Makefile')
-rw-r--r--devel/pharmacy/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/devel/pharmacy/Makefile b/devel/pharmacy/Makefile
index 3878e2bf645..72e42fc8490 100644
--- a/devel/pharmacy/Makefile
+++ b/devel/pharmacy/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= jedgar@FreeBSD.org
COMMENT= GNOME frontend for CVS
USE_X_PREFIX= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
USE_GNOME= yes
GNU_CONFIGURE= yes
@@ -22,12 +23,12 @@ CONFIGURE_ENV+= CPPCFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
- s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
- s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|\(DATADIRNAME=\)lib|\1share|g ; \
+ s|USE_INCLUDED_LIBINTL=yes|#&|g ; \
+ s|\$$(top_builddir)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|\(\$$(datadir)/\)gnome/|\1|g ; \
+ s|\$$(datadir)/locale|$$(prefix)/share/locale|g'
.include <bsd.port.mk>