aboutsummaryrefslogtreecommitdiffstats
path: root/devel/projectcenter.app/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-08-28 09:42:30 +0800
committerdinoex <dinoex@FreeBSD.org>2003-08-28 09:42:30 +0800
commit19c7397033ce2e1357a03e47e1e02e36c4e8846d (patch)
tree4bcc406896488d66df12ae8d93a36a4982246190 /devel/projectcenter.app/Makefile
parentd5d5bcf1363e6e9304258d9d58bd3bd8f6d31e6f (diff)
downloadfreebsd-ports-graphics-19c7397033ce2e1357a03e47e1e02e36c4e8846d.tar.gz
freebsd-ports-graphics-19c7397033ce2e1357a03e47e1e02e36c4e8846d.tar.zst
freebsd-ports-graphics-19c7397033ce2e1357a03e47e1e02e36c4e8846d.zip
- use new hook USE_GNUSTEP in bsd.port.mk
Diffstat (limited to 'devel/projectcenter.app/Makefile')
-rw-r--r--devel/projectcenter.app/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/devel/projectcenter.app/Makefile b/devel/projectcenter.app/Makefile
index 24f9598a660..803697d5508 100644
--- a/devel/projectcenter.app/Makefile
+++ b/devel/projectcenter.app/Makefile
@@ -20,6 +20,10 @@ PREFIX= ${LOCALBASE}/GNUstep
NO_MTREE= yes
WRKSRC= ${WRKDIR}/ProjectCenter
USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
MAKEFILE= GNUmakefile
MAKE_ENV+= ADDITIONAL_INCLUDE_DIRS="-I${WRKSRC}"
MAKE_ENV+= ADDITIONAL_LIB_DIRS="-L${WRKSRC}/PCLib/shared_obj/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu"
@@ -27,13 +31,6 @@ MAKE_ENV+= ADDITIONAL_LIB_DIRS="-L${WRKSRC}/PCLib/shared_obj/${GNU_ARCH}/${OPSYS
FIXME= GNUmakefile.bundles GNUmakefile.preamble \
PCLib/GNUmakefile.preamble
-.include <bsd.port.pre.mk>
-
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
-.include "${PORTSDIR}/devel/gnustep/bsd.gnustep.mk"
-
# Quick workaround until I find out how to set the real path in the code
post-patch:
.for file in PCLib/PCBundleLoader.m PCAppController.m
@@ -47,4 +44,4 @@ post-patch:
${WRKSRC}/${file}.sed > ${WRKSRC}/${file}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>