aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-Jinja2
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2007-02-16 18:05:44 +0800
committernivit <nivit@FreeBSD.org>2007-02-16 18:05:44 +0800
commitff3ed03be1981a097d35fd609379ca308b81f47c (patch)
tree987327bb45a8ac35d6fa3e764a450effefc014fc /devel/py-Jinja2
parentf9adbc6c31e689a087716303af6f2b2cb2af15ec (diff)
downloadfreebsd-ports-graphics-ff3ed03be1981a097d35fd609379ca308b81f47c.tar.gz
freebsd-ports-graphics-ff3ed03be1981a097d35fd609379ca308b81f47c.tar.zst
freebsd-ports-graphics-ff3ed03be1981a097d35fd609379ca308b81f47c.zip
Jinja is a small but very fast and easy to use stand-alone template engine
written in pure python. Since version 0.6 it uses a new parser that increases parsing performance a lot by caching the nodelists on the harddisk if wanted. It includes multiple template inheritance and other features like simple value escaping. Author: Armin Ronacher WWW: http://wsgiarea.pocoo.org/jinja/
Diffstat (limited to 'devel/py-Jinja2')
-rw-r--r--devel/py-Jinja2/Makefile31
-rw-r--r--devel/py-Jinja2/distinfo3
-rw-r--r--devel/py-Jinja2/pkg-descr9
-rw-r--r--devel/py-Jinja2/pkg-plist4
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/py-Jinja2/Makefile b/devel/py-Jinja2/Makefile
new file mode 100644
index 00000000000..7d7cab7e6e2
--- /dev/null
+++ b/devel/py-Jinja2/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: jinja
+# Date created: 2007-02-14
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Jinja
+PORTVERSION= 0.9
+CATEGORIES= devel python
+MASTER_SITES= http://cheeseshop.python.org/packages/source/J/${PORTNAME}/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= A fast, and easy to use stand-alone template engine
+
+BUILD_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+
+PLIST_SUB= EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
+ PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION} \
+ PYJINJA_EGG=${PYJINJA_EGG}
+
+EASY_INSTALL_CMD?= easy_install-${PYTHON_VER}
+PYJINJA_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+.include <bsd.port.mk>
diff --git a/devel/py-Jinja2/distinfo b/devel/py-Jinja2/distinfo
new file mode 100644
index 00000000000..aa352f39b18
--- /dev/null
+++ b/devel/py-Jinja2/distinfo
@@ -0,0 +1,3 @@
+MD5 (Jinja-0.9.tar.gz) = a5aaebb6285e044b6b9d56facae1c1f2
+SHA256 (Jinja-0.9.tar.gz) = 652db44e332b65fdd797665a52e9f7527e437d2b943bbc010bee88cd38d76bbe
+SIZE (Jinja-0.9.tar.gz) = 55816
diff --git a/devel/py-Jinja2/pkg-descr b/devel/py-Jinja2/pkg-descr
new file mode 100644
index 00000000000..667732afc80
--- /dev/null
+++ b/devel/py-Jinja2/pkg-descr
@@ -0,0 +1,9 @@
+Jinja is a small but very fast and easy to use stand-alone template engine
+written in pure python.
+Since version 0.6 it uses a new parser that increases parsing performance
+a lot by caching the nodelists on the harddisk if wanted.
+It includes multiple template inheritance and other features like simple
+value escaping.
+
+Author: Armin Ronacher
+WWW: http://wsgiarea.pocoo.org/jinja/
diff --git a/devel/py-Jinja2/pkg-plist b/devel/py-Jinja2/pkg-plist
new file mode 100644
index 00000000000..b27007f80d6
--- /dev/null
+++ b/devel/py-Jinja2/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+@unexec %%EASY_INSTALL_CMD%% -q -m -S %D/%%PYTHON_SITELIBDIR%% %%PORTNAME%%==%%PORTVERSION%%
+%%PYTHON_SITELIBDIR%%/%%PYJINJA_EGG%%
+@exec %%EASY_INSTALL_CMD%% -q -N -S %D/%%PYTHON_SITELIBDIR%% %%PORTNAME%%==%%PORTVERSION%%