aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-cfgparse/Makefile
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2008-04-11 15:41:41 +0800
committerclsung <clsung@FreeBSD.org>2008-04-11 15:41:41 +0800
commit01fa51d875e083d74bf8ed480c1f3350043ebc78 (patch)
tree1fa4b67293d8438ba5f018283b4e01d13a993054 /devel/py-cfgparse/Makefile
parentc486bf156e1ac1131d5e0d5c041625d9029148ad (diff)
downloadfreebsd-ports-graphics-01fa51d875e083d74bf8ed480c1f3350043ebc78.tar.gz
freebsd-ports-graphics-01fa51d875e083d74bf8ed480c1f3350043ebc78.tar.zst
freebsd-ports-graphics-01fa51d875e083d74bf8ed480c1f3350043ebc78.zip
cfgparse is Python module for parsing configuration files.
WWW: http://cfgparse.sourceforge.net/ PR: ports/121855 Submitted by: John Ferrell
Diffstat (limited to 'devel/py-cfgparse/Makefile')
-rw-r--r--devel/py-cfgparse/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/py-cfgparse/Makefile b/devel/py-cfgparse/Makefile
new file mode 100644
index 00000000000..91130ff83b8
--- /dev/null
+++ b/devel/py-cfgparse/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: cfgparse
+# Date created: March 18, 2008
+# Whom: John Ferrell
+#
+# $FreeBSD$
+#
+
+PORTNAME= cfgparse
+PORTVERSION= 1.2
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= cfgparse
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= cfgparse-v01_02
+
+MAINTAINER= jdferrell3@yahoo.com
+COMMENT= Python module for parsing configuration files
+
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= cfgparse
+PYDISTUTILS_EGGINFO= ${PYDISTUTILS_PKGNAME:C/[^A-Za-z0-9.]+/_/g}-v01_02-${PYTHON_VERSION:S/thon//}.egg-info
+
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/cfgparse/* ${DOCSDIR}
+.endif
+
+PLIST_SUB= PYTHONVER=${PYTHON_VERSION:S/python//}
+
+.include <bsd.port.mk>