aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ruby-sdl
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2005-02-05 12:59:26 +0800
committerknu <knu@FreeBSD.org>2005-02-05 12:59:26 +0800
commit584984a14cadb1bedf9e267effdafd4aac178618 (patch)
tree27e9d2d6bee9a8d90b9da0364a0514d6acc23097 /devel/ruby-sdl
parentbb4b58c482c462fe675e9cc2b457369555b0b634 (diff)
downloadfreebsd-ports-graphics-584984a14cadb1bedf9e267effdafd4aac178618.tar.gz
freebsd-ports-graphics-584984a14cadb1bedf9e267effdafd4aac178618.tar.zst
freebsd-ports-graphics-584984a14cadb1bedf9e267effdafd4aac178618.zip
The slippery pthread support for systems prior to 502102 has been
dropped and the lang/ruby16_r and lang/ruby18_r ports have been removed, since no one seems to appreciate the partially working solution. Good news is that the pthread support of lang/ruby18 is now enabled by default for newer systems, which means the ruby interpreter is linked with libpthread. This will allow threaded extension libraries to run and work properly on those systems. The --march=cputype flag is disabled because it gets ruby to malfunction and fail to build. I don't know if the problem is in libpthread or in gcc. (It really makes me wonder if they had actually tested before asking me to do this somewhat risky change ;-)
Diffstat (limited to 'devel/ruby-sdl')
-rw-r--r--devel/ruby-sdl/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/devel/ruby-sdl/Makefile b/devel/ruby-sdl/Makefile
index 648ad9fd950..8f8addfb9f1 100644
--- a/devel/ruby-sdl/Makefile
+++ b/devel/ruby-sdl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sdl
PORTVERSION= 0.9.3
+PORTREVISION= 1
CATEGORIES= devel graphics audio ruby
MASTER_SITES= http://www.kmc.gr.jp/~ohai/rubysdl/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -24,7 +25,6 @@ RUBY_OPENGL_WRKSRC_CMD= cd ${RUBY_OPENGL_PORTDIR}; ${MAKE} -V WRKSRC
USE_SDL= mixer image ttf sdl
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-RUBY_WITH_PTHREAD= yes
CONFIGURE_ARGS= --with-sdl-config="sdl11-config" \
--enable-opengl --linkoglmodule \
@@ -42,6 +42,9 @@ DOCS_JA= NEWS.ja README.ja \
${RUBY_RD_HTML_FILES:N*.en.html}
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 502102
+BROKEN= "Systems prior to FreeBSD 502102 are out of support"
+.endif
post-extract:
dir=`${RUBY_OPENGL_WRKSRC_CMD}`; \