aboutsummaryrefslogtreecommitdiffstats
path: root/devel/swigruby
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-11-08 02:08:50 +0800
committerknu <knu@FreeBSD.org>2002-11-08 02:08:50 +0800
commit1c50d73bf069be06b9c5bc534b91d24504a34fd7 (patch)
treef057479197c0a608b26e39430f12ef244b466934 /devel/swigruby
parente50f7517306d62bdd357862a5833e860f733b6a8 (diff)
downloadfreebsd-ports-graphics-1c50d73bf069be06b9c5bc534b91d24504a34fd7.tar.gz
freebsd-ports-graphics-1c50d73bf069be06b9c5bc534b91d24504a34fd7.tar.zst
freebsd-ports-graphics-1c50d73bf069be06b9c5bc534b91d24504a34fd7.zip
- Unbreak with the new g++.
Reported by: bento - Pass "--with-swig=swig1.1" to configure.rb.
Diffstat (limited to 'devel/swigruby')
-rw-r--r--devel/swigruby/Makefile2
-rw-r--r--devel/swigruby/files/patch-ruby.cxx12
2 files changed, 13 insertions, 1 deletions
diff --git a/devel/swigruby/Makefile b/devel/swigruby/Makefile
index ed8eb78adbb..a284637746b 100644
--- a/devel/swigruby/Makefile
+++ b/devel/swigruby/Makefile
@@ -25,7 +25,7 @@ DOCS_JA= README.ja
do-configure:
@cd ${WRKSRC}; \
- ${SETENV} ${CONFIGURE_ENV} ${RUBY} configure.rb
+ ${SETENV} ${CONFIGURE_ENV} ${RUBY} configure.rb --with-swig=swig1.1
post-install:
.if !defined(NOPORTDOCS)
diff --git a/devel/swigruby/files/patch-ruby.cxx b/devel/swigruby/files/patch-ruby.cxx
new file mode 100644
index 00000000000..93e75bfbec5
--- /dev/null
+++ b/devel/swigruby/files/patch-ruby.cxx
@@ -0,0 +1,12 @@
+--- ruby.cxx.orig Thu May 25 01:18:29 2000
++++ ruby.cxx Fri Nov 8 03:05:43 2002
+@@ -840,3 +840,3 @@
+ // ---------------------------------------------------------------------
+-char *RUBY::ruby_typemap_lookup(char *op, DataType *type, char *pname, char *source, char *target, WrapperFunction *f = 0) {
++char *RUBY::ruby_typemap_lookup(char *op, DataType *type, char *pname, char *source, char *target, WrapperFunction *f) {
+ static String s;
+@@ -903,3 +903,3 @@
+ // ---------------------------------------------------------------------
+-char *RUBY::to_VALUE(DataType *type, char *value, int raw = 0) {
++char *RUBY::to_VALUE(DataType *type, char *value, int raw) {
+ static String str;