aboutsummaryrefslogtreecommitdiffstats
path: root/devel/tcllib
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2015-06-05 15:26:27 +0800
committermi <mi@FreeBSD.org>2015-06-05 15:26:27 +0800
commitd9b73ea7968cd4a0a84042c7584886e5c2c6bf1f (patch)
treec81f66904f2f59b548c3441e1fe6f1bd09c84115 /devel/tcllib
parentce23d6c50d2653d586a477a0b15c2ad667c09146 (diff)
downloadfreebsd-ports-graphics-d9b73ea7968cd4a0a84042c7584886e5c2c6bf1f.tar.gz
freebsd-ports-graphics-d9b73ea7968cd4a0a84042c7584886e5c2c6bf1f.tar.zst
freebsd-ports-graphics-d9b73ea7968cd4a0a84042c7584886e5c2c6bf1f.zip
Split the compiled pieces out of tcllib into a slave port of its own to avoid
a circular dependency: compiling C-files of tcllib requires critcl, but critcl requires the cmdline (pure-Tcl) component of tcllib. PR: 195863, 200612 Approved by: gahr (blanket)
Diffstat (limited to 'devel/tcllib')
-rw-r--r--devel/tcllib/Makefile15
-rw-r--r--devel/tcllib/pkg-descr4
-rw-r--r--devel/tcllib/pkg-plist4
3 files changed, 10 insertions, 13 deletions
diff --git a/devel/tcllib/Makefile b/devel/tcllib/Makefile
index e54885bffb4..5f73877364b 100644
--- a/devel/tcllib/Makefile
+++ b/devel/tcllib/Makefile
@@ -16,19 +16,15 @@ LICENSE_NAME= Tcl/Tk License
LICENSE_FILE= ${WRKSRC}/license.terms
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BUILD_DEPENDS= critcl:${PORTSDIR}/devel/critcl
-
OPTIONS_DEFINE= DOCS MANPAGES
WRKSRC= ${WRKDIR}/tcllib-tcllib_${DISTVERSION}
USES+= tcl
GNU_CONFIGURE= yes
CONFIGURE_ENV+= ac_cv_path_tclsh="${TCLSH}"
-ALL_TARGET= critcl
MAKE_ENV+= LANG=C
PORTDOCS= *
REINPLACE_ARGS= -i'""'
-PLIST_SUB+= BINARCH=${OPSYS:tl}-${ARCH:S/i386/ix86/}
INSTALL_ARGS= -pkgs -pkg-path ${STAGEDIR}${PREFIX}/lib/tcllib \
-apps -app-path ${STAGEDIR}${PREFIX}/bin \
@@ -39,7 +35,7 @@ INSTALL_ARGS= -pkgs -pkg-path ${STAGEDIR}${PREFIX}/lib/tcllib \
#
# Man pages
#
-.if ${PORT_OPTIONS:MMANPAGES}
+.if ${PORT_OPTIONS:MMANPAGES} && !(defined(ALL_TARGET) && ${ALL_TARGET:Mcritcl})
ALL_TARGET+= nroff-doc
INSTALL_ARGS+= -nroff-path ${STAGEDIR}${PREFIX}/man/mann
PLIST_SUB+= MAN=""
@@ -51,13 +47,14 @@ PLIST_SUB+= MAN="@comment "
#
# HTML documentation
#
-.if ${PORT_OPTIONS:MDOCS}
+.if ${PORT_OPTIONS:MDOCS} && !(defined(ALL_TARGET) && ${ALL_TARGET:Mcritcl})
ALL_TARGET+= html-doc
INSTALL_ARGS+= -html-path ${STAGEDIR}${DOCSDIR}
.else
INSTALL_ARGS+= -no-html
.endif
+.if !target(post-patch)
post-patch:
#
# Ensure, the detailed output of vendors' self-tests is
@@ -96,12 +93,12 @@ post-patch:
for man in `${FIND} . -name "*.n"`; do \
${MV} $$man `echo $$man | ${SED} -e 's|n$$|tcllib.n|'`; \
done
- cd ${WRKSRC}/modules/json/c && ${YACC} -b json json.y
+.endif
+.if !target(do-install)
do-install:
cd ${WRKSRC} && ${TCLSH} ./installer.tcl ${INSTALL_ARGS}
- ${RM} ${WRKSRC}/modules/tcllibc/license.terms
- ${CP} -Rp ${WRKSRC}/modules/tcllibc ${STAGEDIR}${PREFIX}/lib/tcllib/
+.endif
test check regression-test: build
cd ${WRKSRC} && ${SETENV} LANG=C LC_ALL=C DISPLAY= ${MAKE} test
diff --git a/devel/tcllib/pkg-descr b/devel/tcllib/pkg-descr
index 724a9786244..826a1c12523 100644
--- a/devel/tcllib/pkg-descr
+++ b/devel/tcllib/pkg-descr
@@ -9,4 +9,8 @@ documentation at
to get the idea.
+This port installs pure-Tcl versions of the modules only.
+C-implementations -- for some of the modules -- can be added by
+installing devel/tcllibc port.
+
WWW: http://tcllib.sourceforge.net/
diff --git a/devel/tcllib/pkg-plist b/devel/tcllib/pkg-plist
index 66932c9430a..60fdd5746c6 100644
--- a/devel/tcllib/pkg-plist
+++ b/devel/tcllib/pkg-plist
@@ -554,10 +554,6 @@ lib/tcllib/struct/tree_c.tcl
lib/tcllib/struct/tree_tcl.tcl
lib/tcllib/tar/pkgIndex.tcl
lib/tcllib/tar/tar.tcl
-lib/tcllib/tcllibc/critcl-rt.tcl
-lib/tcllib/tcllibc/%%BINARCH%%/tcllibc.so
-lib/tcllib/tcllibc/pkgIndex.tcl
-lib/tcllib/tcllibc/teapot.txt
lib/tcllib/tepam/pkgIndex.tcl
lib/tcllib/tepam/tepam.tcl
lib/tcllib/tepam/tepam_doc_gen.tcl