aboutsummaryrefslogtreecommitdiffstats
path: root/devel/xxgdb
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-06-20 16:01:36 +0800
committerasami <asami@FreeBSD.org>1995-06-20 16:01:36 +0800
commita1eb090fcf6876c1d03019dfdb7487712fd1032e (patch)
tree0e44641bdc933d3926b535e39a5b94c5f76a803b /devel/xxgdb
parentf4c96d3ff98c9649e0c553a707fb9517267380b4 (diff)
downloadfreebsd-ports-graphics-a1eb090fcf6876c1d03019dfdb7487712fd1032e.tar.gz
freebsd-ports-graphics-a1eb090fcf6876c1d03019dfdb7487712fd1032e.tar.zst
freebsd-ports-graphics-a1eb090fcf6876c1d03019dfdb7487712fd1032e.zip
Compile and install xxgdbiowin. It is required by the "iowin" feature
of the debugger. Pointed-out by: murphyp1@AIXDev1.ais.msu.edu (Patrick Murphy)
Diffstat (limited to 'devel/xxgdb')
-rw-r--r--devel/xxgdb/Makefile12
-rw-r--r--devel/xxgdb/pkg-plist1
2 files changed, 12 insertions, 1 deletions
diff --git a/devel/xxgdb/Makefile b/devel/xxgdb/Makefile
index f0b128cbd4a..de1512bbf22 100644
--- a/devel/xxgdb/Makefile
+++ b/devel/xxgdb/Makefile
@@ -3,7 +3,7 @@
# Date created: 2 May 1995
# Whom: jkh
#
-# $Id: Makefile,v 1.8 1995/04/09 10:05:08 asami Exp $
+# $Id: Makefile,v 1.1.1.1 1995/05/03 05:39:09 asami Exp $
#
DISTNAME= xxgdb-1.11
@@ -15,4 +15,14 @@ MAINTAINER= asami@FreeBSD.ORG
USE_IMAKE= yes
+# This isn't included in the original Imakefile for some reason.
+# Yes, I know this will recompile the program every time, but
+# we have the cookie anyway and it's much easier this way
+# than modifying the Imakefile.
+post-build:
+ cd ${WRKSRC}; gcc -o xxgdbiowin -m486 -O2 xxgdbiowin.c
+
+post-install:
+ install -c -s ${WRKSRC}/xxgdbiowin ${PREFIX}/bin
+
.include <bsd.port.mk>
diff --git a/devel/xxgdb/pkg-plist b/devel/xxgdb/pkg-plist
index dc6d7beb144..1dd090059b2 100644
--- a/devel/xxgdb/pkg-plist
+++ b/devel/xxgdb/pkg-plist
@@ -1,5 +1,6 @@
@mode 755
bin/xxgdb
+bin/xxgdbiowin
@mode 444
man/man1/xxgdb.1.gz
lib/X11/app-defaults/XDbx