aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-01-13 02:29:58 +0800
committerknu <knu@FreeBSD.org>2002-01-13 02:29:58 +0800
commit05425d9c82cb9f5a88b682703ae59f401f1885f5 (patch)
tree8060bcb9504e08594da4f72fe0b2647747aa11a9 /devel
parent1926c63a179cbde78acaf3c54aa119e7537a3bd0 (diff)
downloadfreebsd-ports-graphics-05425d9c82cb9f5a88b682703ae59f401f1885f5.tar.gz
freebsd-ports-graphics-05425d9c82cb9f5a88b682703ae59f401f1885f5.tar.zst
freebsd-ports-graphics-05425d9c82cb9f5a88b682703ae59f401f1885f5.zip
Add ruby-pcsc-lite, Ruby extension for the UNIX PC/SC Lite API
(MUSCLE). PR: ports/33321 Submitted by: Toni Andjelkovic <toni@soth.at>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-pcsc-lite/Makefile41
-rw-r--r--devel/ruby-pcsc-lite/distinfo1
-rw-r--r--devel/ruby-pcsc-lite/pkg-comment1
-rw-r--r--devel/ruby-pcsc-lite/pkg-descr4
-rw-r--r--devel/ruby-pcsc-lite/pkg-plist6
6 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4b2888210b6..7eee11d1395 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -564,6 +564,7 @@
SUBDIR += ruby-mo
SUBDIR += ruby-mock
SUBDIR += ruby-optparse
+ SUBDIR += ruby-pcsc-lite
SUBDIR += ruby-property
SUBDIR += ruby-racc
SUBDIR += ruby-racc-runtime
diff --git a/devel/ruby-pcsc-lite/Makefile b/devel/ruby-pcsc-lite/Makefile
new file mode 100644
index 00000000000..7e17f32220d
--- /dev/null
+++ b/devel/ruby-pcsc-lite/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: PCSC-ruby
+# Date created: 27 Dec 2001
+# Whom: Toni Andjelkovic <toni@ants.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pcsc-lite
+PORTVERSION= 0.5
+CATEGORIES= devel ruby
+MASTER_SITES= http://www.ants.at/ruby/PCSC-ruby/dist/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= PCSC-ruby-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= toni@ants.at
+
+LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+RUBY_SETUP= install.rb
+
+WRKSRC= ${WRKDIR}/PCSC-ruby
+
+DOCS= README.txt
+EXAMPLES= examples/test.rb examples/pcsclient.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.for f in ${EXAMPLES}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-pcsc-lite/distinfo b/devel/ruby-pcsc-lite/distinfo
new file mode 100644
index 00000000000..f03d58e9413
--- /dev/null
+++ b/devel/ruby-pcsc-lite/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/PCSC-ruby-0.5.tar.gz) = e0f3d37ac326f1daf8870b041048cdbf
diff --git a/devel/ruby-pcsc-lite/pkg-comment b/devel/ruby-pcsc-lite/pkg-comment
new file mode 100644
index 00000000000..e99aaaf8bd0
--- /dev/null
+++ b/devel/ruby-pcsc-lite/pkg-comment
@@ -0,0 +1 @@
+Ruby extension for the UNIX PC/SC Lite API (MUSCLE)
diff --git a/devel/ruby-pcsc-lite/pkg-descr b/devel/ruby-pcsc-lite/pkg-descr
new file mode 100644
index 00000000000..bd935e3a876
--- /dev/null
+++ b/devel/ruby-pcsc-lite/pkg-descr
@@ -0,0 +1,4 @@
+Ruby extension for the UNIX PC/SC Lite API (MUSCLE).
+
+Author: Toni Andjelkovic <toni@ants.at>
+WWW: http://www.ants.at/ruby/PCSC-ruby/
diff --git a/devel/ruby-pcsc-lite/pkg-plist b/devel/ruby-pcsc-lite/pkg-plist
new file mode 100644
index 00000000000..2b904ea9d46
--- /dev/null
+++ b/devel/ruby-pcsc-lite/pkg-plist
@@ -0,0 +1,6 @@
+%%RUBY_ARCHLIBDIR%%/PCSC.so
+%%PORTDOCS%%%%RUBY_DOCDIR%%/pcsc-lite/README.txt
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/pcsc-lite/test.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/pcsc-lite/pcsclient.rb
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/pcsc-lite
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/pcsc-lite