aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-07-14 00:57:14 +0800
committerpi <pi@FreeBSD.org>2016-07-14 00:57:14 +0800
commit07284fca3cfa8fb43e59f85dfde4b21db2907a24 (patch)
treeb7004f96686c6ab6a5f28dbde9d7b39316ff3d23 /devel
parent1b85e075e1f52cee33fc3408a7d4d9bcd9e9e42c (diff)
downloadfreebsd-ports-graphics-07284fca3cfa8fb43e59f85dfde4b21db2907a24.tar.gz
freebsd-ports-graphics-07284fca3cfa8fb43e59f85dfde4b21db2907a24.tar.zst
freebsd-ports-graphics-07284fca3cfa8fb43e59f85dfde4b21db2907a24.zip
New port: devel/py-cluster
Python-cluster is a simple package that allows to create several groups (clusters) of objects from a list. It's meant to be flexible and able to cluster any object. To ensure this kind of flexibility, you need not only to supply the list of objects, but also a function that calculates the similarity between two of those objects. For simple datatypes, like integers, this can be as simple as a subtraction, but more complex calculations are possible. WWW: https://pypi.python.org/pypi/cluster PR: 211052 Submitted by: Danilo G. Baio <dbaio@bsd.com.br>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-cluster/Makefile23
-rw-r--r--devel/py-cluster/distinfo3
-rw-r--r--devel/py-cluster/pkg-descr9
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 68f8b05c712..7bcfbd0ad87 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4006,6 +4006,7 @@
SUBDIR += py-clint
SUBDIR += py-clonedigger
SUBDIR += py-cloudpickle
+ SUBDIR += py-cluster
SUBDIR += py-cmdln
SUBDIR += py-codecov
SUBDIR += py-codegen
diff --git a/devel/py-cluster/Makefile b/devel/py-cluster/Makefile
new file mode 100644
index 00000000000..a3b275fe28e
--- /dev/null
+++ b/devel/py-cluster/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= cluster
+PORTVERSION= 1.3.1
+DISTVERSIONPREFIX= v
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dbaio@bsd.com.br
+COMMENT= Create several groups (clusters) of objects from a list in Python
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= exhuma
+GH_PROJECT= python-cluster
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-cluster/distinfo b/devel/py-cluster/distinfo
new file mode 100644
index 00000000000..bab7aedd884
--- /dev/null
+++ b/devel/py-cluster/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1468020597
+SHA256 (exhuma-python-cluster-v1.3.1_GH0.tar.gz) = f53411f76d96a98a90dff7ad0032cb828b96dc8866eeb69465f52f7e3aaaa794
+SIZE (exhuma-python-cluster-v1.3.1_GH0.tar.gz) = 49328
diff --git a/devel/py-cluster/pkg-descr b/devel/py-cluster/pkg-descr
new file mode 100644
index 00000000000..23c22aa27b2
--- /dev/null
+++ b/devel/py-cluster/pkg-descr
@@ -0,0 +1,9 @@
+Python-cluster is a simple package that allows to create several
+groups (clusters) of objects from a list. It's meant to be flexible
+and able to cluster any object. To ensure this kind of flexibility,
+you need not only to supply the list of objects, but also a function
+that calculates the similarity between two of those objects.
+For simple datatypes, like integers, this can be as simple as a
+subtraction, but more complex calculations are possible.
+
+WWW: https://pypi.python.org/pypi/cluster