aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-09-17 15:36:42 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-09-17 15:36:42 +0800
commit0e551808e69f4c0098bdf8b995c6409e9b2d3cc8 (patch)
tree81973fc0ddd8ba0a138f523c6bbbe040c9eab70f /devel
parent3eda53eb7b677a048e78cbe00df2f6f2a0ef6b54 (diff)
downloadfreebsd-ports-graphics-0e551808e69f4c0098bdf8b995c6409e9b2d3cc8.tar.gz
freebsd-ports-graphics-0e551808e69f4c0098bdf8b995c6409e9b2d3cc8.tar.zst
freebsd-ports-graphics-0e551808e69f4c0098bdf8b995c6409e9b2d3cc8.zip
- Set JSON::PP as conditional dependency
- Bump PORTREVISION for dependency change Reported by: kwm
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Devel-Cover/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/devel/p5-Devel-Cover/Makefile b/devel/p5-Devel-Cover/Makefile
index 1910e8c4591..66cc5358e70 100644
--- a/devel/p5-Devel-Cover/Makefile
+++ b/devel/p5-Devel-Cover/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Devel-Cover
PORTVERSION= 0.79
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -20,9 +21,7 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Template-Toolkit>=2:${PORTSDIR}/www/p5-Template-Toolkit \
p5-Pod-Coverage>=0.06:${PORTSDIR}/devel/p5-Pod-Coverage \
p5-PPI-HTML>=1.07:${PORTSDIR}/textproc/p5-PPI-HTML \
- p5-JSON-PP>=0:${PORTSDIR}/converters/p5-JSON-PP \
p5-Parallel-Iterator>=0:${PORTSDIR}/devel/p5-Parallel-Iterator
-
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Differences>=0:${PORTSDIR}/devel/p5-Test-Differences \
@@ -76,4 +75,11 @@ post-install:
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501400
+BUILD_DEPENDS+= p5-JSON-PP>=0:${PORTSDIR}/converters/p5-JSON-PP
+RUN_DEPENDS+= p5-JSON-PP>=0:${PORTSDIR}/converters/p5-JSON-PP
+.endif
+
+.include <bsd.port.post.mk>