aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2011-09-10 15:52:34 +0800
committertota <tota@FreeBSD.org>2011-09-10 15:52:34 +0800
commit1237b77239644e63245e16b94da4ea189cfd499a (patch)
treec99aa64d01aba879ac3ed3a8903e3b892fe1d443 /devel
parente3d30cfa690eaca20b8494e3e9069503a622b024 (diff)
downloadfreebsd-ports-graphics-1237b77239644e63245e16b94da4ea189cfd499a.tar.gz
freebsd-ports-graphics-1237b77239644e63245e16b94da4ea189cfd499a.tar.zst
freebsd-ports-graphics-1237b77239644e63245e16b94da4ea189cfd499a.zip
- Add a new port: devel/R-cran-proto
proto (google code name r-proto) is an R package which facilitates a style of programming known as prototype-based programming. Prototype-based programming is a type of object oriented (OO) programming in which classes and objects are unified into a single concept, prototypes. This makes proto and prototye programming simpler than the usual OO model yet it retains the OO features of inheritance (known as delegation in the prototype model) and OO dispatch. Applications, News, Additional Information sources, Proto Bugs and Avoiding R Bugs sections are given below while associated Links are in the http://code.google.com/p/r-proto/wiki/Links WWW: http://code.google.com/p/r-proto/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/R-cran-proto/Makefile22
-rw-r--r--devel/R-cran-proto/distinfo2
-rw-r--r--devel/R-cran-proto/pkg-descr12
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d91d315a3bb..9f885d68f65 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -14,6 +14,7 @@
SUBDIR += R-cran-iterators
SUBDIR += R-cran-itertools
SUBDIR += R-cran-plyr
+ SUBDIR += R-cran-proto
SUBDIR += R-cran-reshape
SUBDIR += SpecTcl
SUBDIR += ZendOptimizer
diff --git a/devel/R-cran-proto/Makefile b/devel/R-cran-proto/Makefile
new file mode 100644
index 00000000000..22512cf6565
--- /dev/null
+++ b/devel/R-cran-proto/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: R-cran-proto
+# Date created: 2011-09-09
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= proto
+DISTVERSION= 0.3-9.2
+CATEGORIES= devel
+PKGNAMEPREFIX= R-cran-
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Prototype object-based programming
+
+LICENSE= GPLv2
+
+USE_R_MOD= yes
+R_MOD_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/R-cran-proto/distinfo b/devel/R-cran-proto/distinfo
new file mode 100644
index 00000000000..5eec343f0ce
--- /dev/null
+++ b/devel/R-cran-proto/distinfo
@@ -0,0 +1,2 @@
+SHA256 (proto_0.3-9.2.tar.gz) = ba475a9bcdb8e4b45cb35994eb9d34ac38d0f97944e44c2f40ce19e118f1534a
+SIZE (proto_0.3-9.2.tar.gz) = 565083
diff --git a/devel/R-cran-proto/pkg-descr b/devel/R-cran-proto/pkg-descr
new file mode 100644
index 00000000000..ebce3194056
--- /dev/null
+++ b/devel/R-cran-proto/pkg-descr
@@ -0,0 +1,12 @@
+proto (google code name r-proto) is an R package which facilitates
+a style of programming known as prototype-based programming.
+Prototype-based programming is a type of object oriented (OO)
+programming in which classes and objects are unified into a single
+concept, prototypes. This makes proto and prototye programming
+simpler than the usual OO model yet it retains the OO features of
+inheritance (known as delegation in the prototype model) and OO
+dispatch. Applications, News, Additional Information sources, Proto
+Bugs and Avoiding R Bugs sections are given below while associated
+Links are in the http://code.google.com/p/r-proto/wiki/Links
+
+WWW: http://code.google.com/p/r-proto/