aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2005-06-08 22:45:19 +0800
committerlawrance <lawrance@FreeBSD.org>2005-06-08 22:45:19 +0800
commit144a108ad310e767e4515dd00aa8d57e75e9d3cf (patch)
treecc8697567380551faf62fc42b559a51c06ca39e7 /devel
parent6583b4612f746fa02495a638d8ec038da163da6c (diff)
downloadfreebsd-ports-graphics-144a108ad310e767e4515dd00aa8d57e75e9d3cf.tar.gz
freebsd-ports-graphics-144a108ad310e767e4515dd00aa8d57e75e9d3cf.tar.zst
freebsd-ports-graphics-144a108ad310e767e4515dd00aa8d57e75e9d3cf.zip
Add gwenhywfar 1.13.2, multi-platform helper library for networking and
security applications. PR: ports/80795 (based on) Submitted by: Peter Cornelius <pcc.at.gmx.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/gwenhywfar/Makefile68
-rw-r--r--devel/gwenhywfar/distinfo2
-rw-r--r--devel/gwenhywfar/files/patch-configure20
-rw-r--r--devel/gwenhywfar/files/patch-test_Makefile.in11
-rw-r--r--devel/gwenhywfar/files/patch-tools_dlgtest_Makefile.in11
-rw-r--r--devel/gwenhywfar/files/patch-tools_typemaker_Makefile.in11
-rw-r--r--devel/gwenhywfar/files/patch-tools_xmlmerge_Makefile.in11
-rw-r--r--devel/gwenhywfar/pkg-descr17
-rw-r--r--devel/gwenhywfar/pkg-plist120
10 files changed, 272 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8aaf01c7904..9037675c9fe 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -337,6 +337,7 @@
SUBDIR += gtranslator
SUBDIR += guikachu
SUBDIR += gvd
+ SUBDIR += gwenhywfar
SUBDIR += happydoc
SUBDIR += hapy
SUBDIR += hptools
diff --git a/devel/gwenhywfar/Makefile b/devel/gwenhywfar/Makefile
new file mode 100644
index 00000000000..f5b0ff66762
--- /dev/null
+++ b/devel/gwenhywfar/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: gwenhywfar
+# Date created: 2005-05-05
+# Whom: Peter Cornelius <pcc.at.gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gwenhywfar
+PORTVERSION= 1.13.2
+CATEGORIES= devel net security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= lawrance@FreeBSD.org
+COMMENT= Multi-platform helper library for networking and security applications
+
+OPTIONS= SSLDEBUG "Enable gwenhywfar SSL debug (if SSL enabled)" off \
+ MEMDEBUG "Enable memory debugger statistic" off
+
+USE_LIBTOOL_VER=15
+USE_GETTEXT= yes
+USE_OPENSSL= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS+= %%PREFIX%%/lib/gwenhywfar/plugins/17/dbio
+ALL_TARGET= all
+
+# Examples to be installed from ${WRKSRC}/doc
+EXAMPLE_FILES= STYLE \
+ apidoc.h \
+ db2.png \
+ plugindescr.xml \
+ plugindescr.xsd \
+ plugindescr.xsd.in \
+ testdialog.xml
+
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+ALL_TARGET+= srcdoc
+PORTDOCS=*
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SSLDEBUG)
+# Enable appending of SSL connection in/output to /tmp/{read|written}.bin.
+CFLAGS+= -DGWEN_SSL_DEBUG
+.endif
+
+# Enable printing of memory debugger statistic at runtime.
+.if defined(WITH_MEMDEBUG)
+CFLAGS+= -DGWEN_MEMORY_DEBUG
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_CMD} Installing documentation...
+ ${MKDIR} ${EXAMPLESDIR}
+.for file in ${EXAMPLE_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${EXAMPLESDIR}
+.endfor
+ ${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && ${FIND} apidoc -mindepth 1 \! -type d \
+ -exec ${ECHO_CMD} "{} -> ${DOCSDIR}/{}" \; \
+ -exec ${INSTALL_DATA} ${WRKSRC}/{} ${DOCSDIR} \;
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/gwenhywfar/distinfo b/devel/gwenhywfar/distinfo
new file mode 100644
index 00000000000..50a7fd4b266
--- /dev/null
+++ b/devel/gwenhywfar/distinfo
@@ -0,0 +1,2 @@
+MD5 (gwenhywfar-1.13.2.tar.gz) = d1a82b8f84fc37c41348dcf69a08cba8
+SIZE (gwenhywfar-1.13.2.tar.gz) = 1085838
diff --git a/devel/gwenhywfar/files/patch-configure b/devel/gwenhywfar/files/patch-configure
new file mode 100644
index 00000000000..27648a07ceb
--- /dev/null
+++ b/devel/gwenhywfar/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig Sun May 1 07:42:05 2005
++++ configure Sat Jun 4 23:17:50 2005
+@@ -27956,7 +27956,7 @@
+ lprefix="${srcdir}"
+ lprefix=`( cd ${lprefix} ; pwd )`
+
+-rm -Rf gwenhywfar &>/dev/null
++rm -Rf gwenhywfar 2>/dev/null
+ mkdir gwenhywfar
+ GWEN_HEADER_FILES="doc/apidoc.h"
+ for d in ${GWEN_HEADER_DIRS}; do
+@@ -27981,7 +27981,7 @@
+ lprefix="${srcdir}"
+ lprefix=`( cd ${lprefix} ; pwd )`
+ for d in ${GWEN_MODULES}; do
+- rm -Rf gwenhywfar/$d &>/dev/null
++ rm -Rf gwenhywfar/$d 2>/dev/null
+ mkdir gwenhywfar/$d
+ # FIXME: This needs to be fixed again: The sources are in gwenui,
+ # but the headers will be installed in gwenhywfar/ui.
diff --git a/devel/gwenhywfar/files/patch-test_Makefile.in b/devel/gwenhywfar/files/patch-test_Makefile.in
new file mode 100644
index 00000000000..69ec72a26d4
--- /dev/null
+++ b/devel/gwenhywfar/files/patch-test_Makefile.in
@@ -0,0 +1,11 @@
+--- test/Makefile.in.orig Sun May 1 07:42:01 2005
++++ test/Makefile.in Sat Jun 4 23:51:47 2005
+@@ -273,7 +273,7 @@
+ gwentest_SOURCES = gwentest.c
+ gwentest_LDADD = \
+ -L/mingw/lib -L$(top_builddir)/src $(gwenhywfar_libs) \
+- -L$(top_builddir)/gwenui $(libsui)
++ -L$(top_builddir)/gwenui $(libsui) $(LTLIBINTL)
+
+ EXTRA_DIST = README.MSVC gwentest.vcproj
+ all: all-am
diff --git a/devel/gwenhywfar/files/patch-tools_dlgtest_Makefile.in b/devel/gwenhywfar/files/patch-tools_dlgtest_Makefile.in
new file mode 100644
index 00000000000..0d5b24a4327
--- /dev/null
+++ b/devel/gwenhywfar/files/patch-tools_dlgtest_Makefile.in
@@ -0,0 +1,11 @@
+--- tools/dlgtest/Makefile.in.orig Sun May 1 07:42:02 2005
++++ tools/dlgtest/Makefile.in Sat Jun 4 23:47:19 2005
+@@ -276,7 +276,7 @@
+ dlgtest_LDADD = \
+ -L$(top_builddir)/src $(gwenhywfar_libs) \
+ -L$(top_builddir)/gwenui $(gwenhywfar_libsui) \
+- -L/mingw/lib $(PROG_LIBRARIES)
++ -L/mingw/lib $(PROG_LIBRARIES) $(LTLIBINTL)
+
+ all: all-am
+
diff --git a/devel/gwenhywfar/files/patch-tools_typemaker_Makefile.in b/devel/gwenhywfar/files/patch-tools_typemaker_Makefile.in
new file mode 100644
index 00000000000..760633a7842
--- /dev/null
+++ b/devel/gwenhywfar/files/patch-tools_typemaker_Makefile.in
@@ -0,0 +1,11 @@
+--- tools/typemaker/Makefile.in.orig Sun May 1 07:42:02 2005
++++ tools/typemaker/Makefile.in Sat Jun 4 23:48:35 2005
+@@ -279,7 +279,7 @@
+ typemaker_SOURCES = args.c main.c phc.c lhc.c ahc.c code_c.c
+ typemaker_LDADD = \
+ -L$(top_builddir)/src $(gwenhywfar_libs) \
+- -L/mingw/lib $(PROG_LIBRARIES)
++ -L/mingw/lib $(PROG_LIBRARIES) $(LTLIBINTL)
+
+ all: all-am
+
diff --git a/devel/gwenhywfar/files/patch-tools_xmlmerge_Makefile.in b/devel/gwenhywfar/files/patch-tools_xmlmerge_Makefile.in
new file mode 100644
index 00000000000..33ee7bcfd6f
--- /dev/null
+++ b/devel/gwenhywfar/files/patch-tools_xmlmerge_Makefile.in
@@ -0,0 +1,11 @@
+--- tools/xmlmerge/Makefile.in.orig Sun May 1 07:42:02 2005
++++ tools/xmlmerge/Makefile.in Sat Jun 4 23:43:29 2005
+@@ -277,7 +277,7 @@
+ xmlmerge_SOURCES = args.c main.c
+ xmlmerge_LDADD = \
+ -L$(top_builddir)/src $(gwenhywfar_libs) \
+- -L/mingw/lib $(PROG_LIBRARIES)
++ -L/mingw/lib $(PROG_LIBRARIES) $(LTLIBINTL)
+
+ all: all-am
+
diff --git a/devel/gwenhywfar/pkg-descr b/devel/gwenhywfar/pkg-descr
new file mode 100644
index 00000000000..694133598b4
--- /dev/null
+++ b/devel/gwenhywfar/pkg-descr
@@ -0,0 +1,17 @@
+This is Gwenhywfar, a multi-platform (*BSD, Linux, MS-Win, etc.)
+helper library for networking and security applications and libraries.
+It is used by several 'finance' ports, and possibly others.
+
+Gwenhywfar includes the following features, among several others:
+- OS abstraction functions for directory and Internet address handling
+ and library loading (src/os/)
+- Networking functions which allow to manage many connections to be used
+ economically even in single threaded applications
+- High-level functions for parsing files with a simplified "XML-like"
+ format and accessing them like a hierarchical database (src/parser/)
+ It is able to process valid XML files, too.
+- High-level cryptographic functions on top of OpenSSL functionality
+ (src/crypt/)
+
+Author: Martin Preuss <martin@libchipcard.de>
+WWW: http://gwenhywfar.sourceforge.net/
diff --git a/devel/gwenhywfar/pkg-plist b/devel/gwenhywfar/pkg-plist
new file mode 100644
index 00000000000..8d0f9e0460d
--- /dev/null
+++ b/devel/gwenhywfar/pkg-plist
@@ -0,0 +1,120 @@
+@comment $FreeBSD$
+bin/mklistdoc
+bin/xmlmerge
+bin/dlgtest
+bin/typemaker
+bin/gwenhywfar-config
+include/gwenhywfar/args.h
+include/gwenhywfar/buffer.h
+include/gwenhywfar/debug.h
+include/gwenhywfar/error.h
+include/gwenhywfar/i18n.h
+include/gwenhywfar/idlist.h
+include/gwenhywfar/inherit.h
+include/gwenhywfar/list.h
+include/gwenhywfar/list1.tmpl
+include/gwenhywfar/list2.h
+include/gwenhywfar/list2.tmpl
+include/gwenhywfar/logger.h
+include/gwenhywfar/memory.h
+include/gwenhywfar/misc.h
+include/gwenhywfar/misc2.h
+include/gwenhywfar/plugin.h
+include/gwenhywfar/plugindescr.h
+include/gwenhywfar/refptr.h
+include/gwenhywfar/ringbuffer.h
+include/gwenhywfar/stringlist.h
+include/gwenhywfar/stringlist2.h
+include/gwenhywfar/waitcallback.h
+include/gwenhywfar/crypt.h
+include/gwenhywfar/keymanager.h
+include/gwenhywfar/keyspec.h
+include/gwenhywfar/md.h
+include/gwenhywfar/padd.h
+include/gwenhywfar/nettransportssl.h
+include/gwenhywfar/bio_buffer.h
+include/gwenhywfar/bio_file.h
+include/gwenhywfar/bio_socket.h
+include/gwenhywfar/bufferedio.h
+include/gwenhywfar/filter.h
+include/gwenhywfar/ipc.h
+include/gwenhywfar/netconnectionhttp.h
+include/gwenhywfar/system.h
+include/gwenhywfar/directory.h
+include/gwenhywfar/fslock.h
+include/gwenhywfar/gwentime.h
+include/gwenhywfar/inetaddr.h
+include/gwenhywfar/inetsocket.h
+include/gwenhywfar/libloader.h
+include/gwenhywfar/process.h
+include/gwenhywfar/base64.h
+include/gwenhywfar/csv.h
+include/gwenhywfar/db.h
+include/gwenhywfar/dbio.h
+include/gwenhywfar/msgengine.h
+include/gwenhywfar/path.h
+include/gwenhywfar/text.h
+include/gwenhywfar/ui/button.h
+include/gwenhywfar/ui/checkbox.h
+include/gwenhywfar/ui/dropdownbox.h
+include/gwenhywfar/ui/editbox.h
+include/gwenhywfar/ui/event.h
+include/gwenhywfar/ui/filedialog.h
+include/gwenhywfar/ui/hline.h
+include/gwenhywfar/ui/hslider.h
+include/gwenhywfar/ui/loader.h
+include/gwenhywfar/ui/messagebox.h
+include/gwenhywfar/ui/scrollwidget.h
+include/gwenhywfar/ui/tablewidget.h
+include/gwenhywfar/ui/textwidget.h
+include/gwenhywfar/ui/ui.h
+include/gwenhywfar/ui/vslider.h
+include/gwenhywfar/ui/widget.h
+include/gwenhywfar/ui/window.h
+include/gwenhywfar/tlv.h
+include/gwenhywfar/xml.h
+include/gwenhywfar/xsd.h
+include/gwenhywfar/net.h
+include/gwenhywfar/netconnection.h
+include/gwenhywfar/netmsg.h
+include/gwenhywfar/nettransport.h
+include/gwenhywfar/nettransportsock.h
+include/gwenhywfar/crypttoken.h
+include/gwenhywfar/gwenhywfar.h
+include/gwenhywfar/gwenhywfarapi.h
+include/gwenhywfar/types.h
+include/gwenhywfar/version.h
+include/gwenpp/waitcallback.h
+etc/gwen-public-ca.crt
+lib/libgwenhywfar.so.30
+lib/libgwenhywfar.so
+lib/libgwenhywfar.a
+lib/libgwenpp.so.16
+lib/libgwenpp.so
+lib/libgwenpp.a
+lib/libgwenui.so.1
+lib/libgwenui.so
+lib/libgwenui.a
+lib/gwenhywfar/plugins/17/dbio/csv.xml
+lib/gwenhywfar/plugins/17/dbio/csv.so.0
+lib/gwenhywfar/plugins/17/dbio/csv.so
+lib/gwenhywfar/plugins/17/dbio/olddb.xml
+lib/gwenhywfar/plugins/17/dbio/olddb.so.0
+lib/gwenhywfar/plugins/17/dbio/olddb.so
+share/aclocal/gwenhywfar.m4
+%%PORTDOCS%%%%EXAMPLESDIR%%/STYLE
+%%PORTDOCS%%%%EXAMPLESDIR%%/apidoc.h
+%%PORTDOCS%%%%EXAMPLESDIR%%/db2.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/plugindescr.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/plugindescr.xsd
+%%PORTDOCS%%%%EXAMPLESDIR%%/plugindescr.xsd.in
+%%PORTDOCS%%%%EXAMPLESDIR%%/testdialog.xml
+share/locale/de/LC_MESSAGES/gwenhywfar.mo
+@dirrm include/gwenhywfar/ui
+@dirrm include/gwenhywfar
+@dirrm include/gwenpp
+@dirrm lib/gwenhywfar/plugins/17/dbio
+@dirrm lib/gwenhywfar/plugins/17
+@dirrm lib/gwenhywfar/plugins
+@dirrm lib/gwenhywfar
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%