aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-03-19 11:14:55 +0800
committermarcus <marcus@FreeBSD.org>2004-03-19 11:14:55 +0800
commit19046464e6aa97d38de4338eefb5cc975ad79618 (patch)
treea71c95a2df9a12ad6d2bda144fa6c68ba562d66d /devel
parentc383b1d678d3e9b179db88d45af55df35221293e (diff)
downloadfreebsd-ports-graphics-19046464e6aa97d38de4338eefb5cc975ad79618.tar.gz
freebsd-ports-graphics-19046464e6aa97d38de4338eefb5cc975ad79618.tar.zst
freebsd-ports-graphics-19046464e6aa97d38de4338eefb5cc975ad79618.zip
Borrow from the OpenLDAP ports, and refuse to build if bind has been
installed with PORT_REPLACES_BASE_BIND defined. PR: 61756 Obtained from: OpenLDAP ports
Diffstat (limited to 'devel')
-rw-r--r--devel/gnome-vfs/Makefile6
-rw-r--r--devel/gnomevfs2/Makefile6
-rw-r--r--devel/nspr/Makefile6
3 files changed, 18 insertions, 0 deletions
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index cab5c551175..8d0347ede42 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -59,4 +59,10 @@ post-patch:
@${REINPLACE_CMD} -e "/^SUBDIRS =/s/test//" \
${WRKSRC}/Makefile.in
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
.include <bsd.port.post.mk>
diff --git a/devel/gnomevfs2/Makefile b/devel/gnomevfs2/Makefile
index cab5c551175..8d0347ede42 100644
--- a/devel/gnomevfs2/Makefile
+++ b/devel/gnomevfs2/Makefile
@@ -59,4 +59,10 @@ post-patch:
@${REINPLACE_CMD} -e "/^SUBDIRS =/s/test//" \
${WRKSRC}/Makefile.in
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
.include <bsd.port.post.mk>
diff --git a/devel/nspr/Makefile b/devel/nspr/Makefile
index 55ef1ef864c..76e9ea7ffbe 100644
--- a/devel/nspr/Makefile
+++ b/devel/nspr/Makefile
@@ -28,6 +28,12 @@ MAKE_ENV= DIST=${WRKSRC}/dist
LIBS= libnspr4.so.1 libplc4.so.1 libplds4.so.1
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
do-install:
${MKDIR} ${PREFIX}/include/nspr
${TAR} -C ${WRKSRC}/dist/include --dereference -cf - . | \