aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-09-04 00:24:01 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-09-04 00:24:01 +0800
commit243f98c3913355733e2e3268cb5d3dc1bb24c70f (patch)
tree7cc37e7e540026f6af96a23e7e1fc944366f1d7d /devel
parentc0b75ab07e8cda22a3c5feeea80798b7b013d30a (diff)
downloadfreebsd-ports-graphics-243f98c3913355733e2e3268cb5d3dc1bb24c70f.tar.gz
freebsd-ports-graphics-243f98c3913355733e2e3268cb5d3dc1bb24c70f.tar.zst
freebsd-ports-graphics-243f98c3913355733e2e3268cb5d3dc1bb24c70f.zip
- Respect PORTEXAMPLES
- Add EXAMPLES option - Convert to new options target helper - Add NO_ARCH - Use BROKEN_RUBY22 - Remove contiguous blank lines - Sort PLIST - Pass maintainership to ruby@
Diffstat (limited to 'devel')
-rw-r--r--devel/ruby-date2/Makefile37
-rw-r--r--devel/ruby-date2/pkg-descr1
-rw-r--r--devel/ruby-date2/pkg-plist10
3 files changed, 19 insertions, 29 deletions
diff --git a/devel/ruby-date2/Makefile b/devel/ruby-date2/Makefile
index 78ec685c9ba..728dacacc41 100644
--- a/devel/ruby-date2/Makefile
+++ b/devel/ruby-date2/Makefile
@@ -8,9 +8,14 @@ MASTER_SITES= http://www.funaba.org/archive/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DIST_SUBDIR= ruby
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ruby@FreeBSD.org
COMMENT= Alternative date class for Ruby
+BROKEN_RUBY22= yes
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+NO_ARCH= yes
USE_RUBY= yes
USE_RUBY_SETUP= yes
RUBY_SETUP= install.rb
@@ -20,28 +25,14 @@ DOCS_JA= MANUAL MANUAL.rd MANUAL.html README
EXAMPLES_EN= cal.rb daylight.rb goodfriday.rb
EXAMPLES_JA= ncal.rb
-OPTIONS_DEFINE= DOCS
-
-post-install:
- ${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/ja
-.for f in ${EXAMPLES_EN}
- ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/
-.endfor
-.for f in ${EXAMPLES_JA}
- ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/ja/
-.endfor
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}/ja
-.for f in ${DOCS_EN}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}/
-.endfor
-.for f in ${DOCS_JA}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}/ja/
-.endfor
-
-.include <bsd.port.pre.mk>
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS_EN} ${STAGEDIR}${RUBY_MODDOCDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS_JA} ${STAGEDIR}${RUBY_MODDOCDIR}/ja/
-.if ${RUBY_VER} >= 2.2
-BROKEN= Does not build
-.endif
+post-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/ja/
+ cd ${WRKSRC}/sample/ && ${INSTALL_DATA} ${EXAMPLES_EN} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/
+ cd ${WRKSRC}/sample/ && ${INSTALL_DATA} ${EXAMPLES_JA} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/ja/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/ruby-date2/pkg-descr b/devel/ruby-date2/pkg-descr
index 26957083a34..63bbfca1249 100644
--- a/devel/ruby-date2/pkg-descr
+++ b/devel/ruby-date2/pkg-descr
@@ -5,5 +5,4 @@ specified freely in this class. The procedures about holiday
(holiday.rb) and date format (parsedate2.rb, strftime.rb and
strptime.rb) are also available.
-
WWW: http://www.funaba.org/en/ruby.html#date2
diff --git a/devel/ruby-date2/pkg-plist b/devel/ruby-date2/pkg-plist
index 7c68af2d31c..786311f33d7 100644
--- a/devel/ruby-date2/pkg-plist
+++ b/devel/ruby-date2/pkg-plist
@@ -1,11 +1,7 @@
%%RUBY_SITELIBDIR%%/date.rb
-%%RUBY_SITELIBDIR%%/parsedate.rb
%%RUBY_SITELIBDIR%%/date/format.rb
%%RUBY_SITELIBDIR%%/date/holiday.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/cal.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/daylight.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/goodfriday.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/ja/ncal.rb
+%%RUBY_SITELIBDIR%%/parsedate.rb
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/MANUAL.en
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/MANUAL.en.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/MANUAL.en.rd
@@ -14,3 +10,7 @@
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/MANUAL.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/MANUAL.rd
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/README
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/cal.rb
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/daylight.rb
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/goodfriday.rb
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/ja/ncal.rb