aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2013-09-11 18:17:53 +0800
committerkoobs <koobs@FreeBSD.org>2013-09-11 18:17:53 +0800
commit2ab3087d5415e1fbc3f55663f298e99326dc0a79 (patch)
tree8290cc8847df1d0d34a772cad1ade162b6d8601c /devel
parentead672a2899378575da331f92ec28ea6ab2b1e2e (diff)
downloadfreebsd-ports-graphics-2ab3087d5415e1fbc3f55663f298e99326dc0a79.tar.gz
freebsd-ports-graphics-2ab3087d5415e1fbc3f55663f298e99326dc0a79.tar.zst
freebsd-ports-graphics-2ab3087d5415e1fbc3f55663f298e99326dc0a79.zip
devel/py-memoryprofiler: [NEW PORT] Line-by-line and process memory usage analysis
memory_profiler is a python module for monitoring memory consumption of a process as well as line-by-line analysis of memory consumption for python programs. It is a pure python module and has the psutil module as optional (but highly recommended) dependencies. WWW: https://github.com/fabianp/memory_profiler PR: ports/181831 Submitted by: Johannes Jost Meixner <xmj@chaot.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-memoryprofiler/Makefile29
-rw-r--r--devel/py-memoryprofiler/distinfo2
-rw-r--r--devel/py-memoryprofiler/pkg-descr7
-rw-r--r--devel/py-memoryprofiler/pkg-plist4
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 49f7db94687..800f003b9d3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3610,6 +3610,7 @@
SUBDIR += py-manuel
SUBDIR += py-mccabe
SUBDIR += py-meliae
+ SUBDIR += py-memoryprofiler
SUBDIR += py-mercurialserver
SUBDIR += py-mez_xml
SUBDIR += py-mimeparse
diff --git a/devel/py-memoryprofiler/Makefile b/devel/py-memoryprofiler/Makefile
new file mode 100644
index 00000000000..e916a7bbef1
--- /dev/null
+++ b/devel/py-memoryprofiler/Makefile
@@ -0,0 +1,29 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= memoryprofiler
+PORTVERSION= 0.27
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= memory_profiler-${PORTVERSION}
+
+MAINTAINER= xmj@chaot.net
+COMMENT= Line-by-line and process memory consumption analysis
+
+LICENSE= BSD
+
+OPTIONS_DEFINE= PSUTIL
+PSUTIL_DESC= Use psutil for better performance
+OPTIONSFILE?= ${PORT_DBDIR}/py-${PORTNAME}/options
+
+.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MPSUTIL}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}-psutil>0:${PORTSDIR}/sysutils/py-psutil
+.endif
+
+USE_PYTHON= 2.6+
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= memory_profiler
+
+.include <bsd.port.mk>
diff --git a/devel/py-memoryprofiler/distinfo b/devel/py-memoryprofiler/distinfo
new file mode 100644
index 00000000000..66409e6ef38
--- /dev/null
+++ b/devel/py-memoryprofiler/distinfo
@@ -0,0 +1,2 @@
+SHA256 (memory_profiler-0.27.tar.gz) = 9473c29a15456435999bfdd3a14f2d3596c997172d5b34acb6e17fe84fc9585f
+SIZE (memory_profiler-0.27.tar.gz) = 12697
diff --git a/devel/py-memoryprofiler/pkg-descr b/devel/py-memoryprofiler/pkg-descr
new file mode 100644
index 00000000000..90cebd67bdb
--- /dev/null
+++ b/devel/py-memoryprofiler/pkg-descr
@@ -0,0 +1,7 @@
+memory_profiler is a python module for monitoring memory consumption of a
+process as well as line-by-line analysis of memory consumption for python
+programs. It is a pure python module and has the psutil module as optional
+(but highly recommended) dependencies.
+
+
+WWW: https://github.com/fabianp/memory_profiler
diff --git a/devel/py-memoryprofiler/pkg-plist b/devel/py-memoryprofiler/pkg-plist
new file mode 100644
index 00000000000..f7fa8648b45
--- /dev/null
+++ b/devel/py-memoryprofiler/pkg-plist
@@ -0,0 +1,4 @@
+bin/mprofile
+%%PYTHON_SITELIBDIR%%/memory_profiler.py
+%%PYTHON_SITELIBDIR%%/memory_profiler.pyo
+%%PYTHON_SITELIBDIR%%/memory_profiler.pyc