aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2003-07-03 02:03:16 +0800
committererwin <erwin@FreeBSD.org>2003-07-03 02:03:16 +0800
commit2d62a94504f0deefeb352201bc6b9360193fc89b (patch)
tree9a7511f86cf80b075ae3a444cc57b17704d092bb /devel
parentb2169381c169f33d04bbbc60d726aa7d9d70c094 (diff)
downloadfreebsd-ports-graphics-2d62a94504f0deefeb352201bc6b9360193fc89b.tar.gz
freebsd-ports-graphics-2d62a94504f0deefeb352201bc6b9360193fc89b.tar.zst
freebsd-ports-graphics-2d62a94504f0deefeb352201bc6b9360193fc89b.zip
Add p5-Test-Pod 0.95, check for POD errors in files.
PR: 54021 Submitted by: Mathieu Arnold <m@absolight.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Pod/Makefile28
-rw-r--r--devel/p5-Test-Pod/distinfo1
-rw-r--r--devel/p5-Test-Pod/pkg-descr4
-rw-r--r--devel/p5-Test-Pod/pkg-plist5
5 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6d25b5210d3..0b695c3a2cf 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -710,6 +710,7 @@
SUBDIR += p5-Test-Exception
SUBDIR += p5-Test-Harness
SUBDIR += p5-Test-Inline
+ SUBDIR += p5-Test-Pod
SUBDIR += p5-Test-Simple
SUBDIR += p5-Test-Unit
SUBDIR += p5-Tie-Cache
diff --git a/devel/p5-Test-Pod/Makefile b/devel/p5-Test-Pod/Makefile
new file mode 100644
index 00000000000..1e88d6fbe9e
--- /dev/null
+++ b/devel/p5-Test-Pod/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Test-Pod
+# Date created: 2 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Pod
+PORTVERSION= 0.95
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Check for POD errors in files
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
+ ${SITE_PERL}/Pod/Simple.pm:${PORTSDIR}/textproc/p5-Pod-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Pod.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Pod/distinfo b/devel/p5-Test-Pod/distinfo
new file mode 100644
index 00000000000..c593936744a
--- /dev/null
+++ b/devel/p5-Test-Pod/distinfo
@@ -0,0 +1 @@
+MD5 (Test-Pod-0.95.tar.gz) = 6b2a233f5f443f5b5789a5cca449d4f4
diff --git a/devel/p5-Test-Pod/pkg-descr b/devel/p5-Test-Pod/pkg-descr
new file mode 100644
index 00000000000..d4b3a6dadeb
--- /dev/null
+++ b/devel/p5-Test-Pod/pkg-descr
@@ -0,0 +1,4 @@
+Check POD files for errors or warnings in a test file, using Pod::Simple to do
+the heavy lifting.
+
+WWW: http://search.cpan.org/dist/Test-Pod/
diff --git a/devel/p5-Test-Pod/pkg-plist b/devel/p5-Test-Pod/pkg-plist
new file mode 100644
index 00000000000..b64a05db7a6
--- /dev/null
+++ b/devel/p5-Test-Pod/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Test/Pod.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Pod/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Pod
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test 2>/dev/null || true